+static __always_inline bool is_evmcs_enabled(void)I have a suggestion. While 'is_evmcs_enabled' name is certainly not
+{
+ return static_branch_unlikely(&enable_evmcs);
+}
worse than 'enable_evmcs', it may still be confusing as it's not clear
which eVMCS is meant: are we running a guest using eVMCS or using eVMCS
ourselves? So what if we rename this to a very explicit 'is_kvm_on_hyperv()'
and hide the implementation details (i.e. 'evmcs') inside?