[PATCH v4 0/4] Simplify extcon_dev_register function.

From: Bumwoo Lee
Date: Thu Mar 02 2023 - 04:02:13 EST


It was modified to increase readability.

Chages from v3:
removed possibility of kfree(NULL).

Chages from v2:
resolved possible memory leak of dev->cables.

Changes from v1:
added return value handling.

Bumwoo Lee (4):
extcon: Removed redundant null checking for class
extcon: Added extcon_alloc_cables to simplify extcon register function
extcon: Added extcon_alloc_muex to simplify extcon register function
extcon: Added extcon_alloc_groups to simplify extcon register function

drivers/extcon/extcon.c | 293 +++++++++++++++++++++++-----------------
1 file changed, 166 insertions(+), 127 deletions(-)

--
2.35.1