Re: [PATCH V2] mm/debug_vm_pgtable: Replace pte_mkhuge() with arch_make_huge_pte()

From: Mike Rapoport
Date: Fri Mar 03 2023 - 05:12:37 EST


On Thu, Mar 02, 2023 at 01:42:21PM +0100, David Hildenbrand wrote:
> On 02.03.23 12:48, Anshuman Khandual wrote:
> > Since the following commit arch_make_huge_pte() should be used directly in
> > generic memory subsystem as a platform provided page table helper, instead
> > of pte_mkhuge(). Change hugetlb_basic_tests() to call arch_make_huge_pte()
> > directly, and update its relevant documentation entry as required.
> >
> > 'commit 16785bd77431 ("mm: merge pte_mkhuge() call into arch_make_huge_pte()")'
> >
> > Cc: Jonathan Corbet <corbet@xxxxxxx>
> > Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>
> > Cc: "Mike Rapoport (IBM)" <rppt@xxxxxxxxxx>
> > Cc: linux-doc@xxxxxxxxxxxxxxx
> > Cc: linux-kernel@xxxxxxxxxxxxxxx
> > Cc: linux-mm@xxxxxxxxx
> > Reported-by: Christophe Leroy <christophe.leroy@xxxxxxxxxx>
> > Link: https://lore.kernel.org/all/1ea45095-0926-a56a-a273-816709e9075e@xxxxxxxxxx/
> > Signed-off-by: Anshuman Khandual <anshuman.khandual@xxxxxxx>
> > ---
> > This applies on latest mainline.
> >
> > Changes in V2:
> >
> > - Send PMD_SHIFT and VM_ACCESS_FLAGS as arguments for arch_make_huge_pte()
> > Changes in V1:
> >
> > https://lore.kernel.org/all/20230302031833.360679-1-anshuman.khandual@xxxxxxx/
> >
> > Documentation/mm/arch_pgtable_helpers.rst | 2 +-
> > mm/debug_vm_pgtable.c | 2 +-
> > 2 files changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/Documentation/mm/arch_pgtable_helpers.rst b/Documentation/mm/arch_pgtable_helpers.rst
> > index 30d9a09f01f4..af3891f895b0 100644
> > --- a/Documentation/mm/arch_pgtable_helpers.rst
> > +++ b/Documentation/mm/arch_pgtable_helpers.rst
> > @@ -214,7 +214,7 @@ HugeTLB Page Table Helpers
> > +---------------------------+--------------------------------------------------+
> > | pte_huge | Tests a HugeTLB |
> > +---------------------------+--------------------------------------------------+
> > -| pte_mkhuge | Creates a HugeTLB |
> > +| arch_make_huge_pte | Creates a HugeTLB |
> > +---------------------------+--------------------------------------------------+
> > | huge_pte_dirty | Tests a dirty HugeTLB |
> > +---------------------------+--------------------------------------------------+
> > diff --git a/mm/debug_vm_pgtable.c b/mm/debug_vm_pgtable.c
> > index af59cc7bd307..7887cc2b75bf 100644
> > --- a/mm/debug_vm_pgtable.c
> > +++ b/mm/debug_vm_pgtable.c
> > @@ -934,7 +934,7 @@ static void __init hugetlb_basic_tests(struct pgtable_debug_args *args)
> > #ifdef CONFIG_ARCH_WANT_GENERAL_HUGETLB
> > pte = pfn_pte(args->fixed_pmd_pfn, args->page_prot);
> > - WARN_ON(!pte_huge(pte_mkhuge(pte)));
> > + WARN_ON(!pte_huge(arch_make_huge_pte(pte, PMD_SHIFT, VM_ACCESS_FLAGS)));
> > #endif /* CONFIG_ARCH_WANT_GENERAL_HUGETLB */
> > }
> > #else /* !CONFIG_HUGETLB_PAGE */
>
>
> IMHO, it's a bit weird that we are starting to call these things "arch_*".
> PTE operations like these are already mostly arch-specific helpers with
> custom implementations (and some generic ones in asm-generic as a fallback).

Yeah, probably a better name for arch_make_huge_pte() would have been
pte_make_huge()

> So this one certainly sticks out now ... anyhow, change itself LGTM ...
>
> --
> Thanks,
>
> David / dhildenb
>

--
Sincerely yours,
Mike.