[PATCH v3 0/5] mm: userfaultfd: refactor and add UFFDIO_CONTINUE_MODE_WP

From: Axel Rasmussen
Date: Mon Mar 06 2023 - 17:50:44 EST


This series, currently based on 6.3-rc1, is divided into two parts:

- Commits 1-4 refactor userfaultfd ioctl code without behavior changes, with the
main goal of improving consistency and reducing the number of function args.
- Commit 5 adds UFFDIO_CONTINUE_MODE_WP.

The refactors are sorted by increasing controversial-ness, the idea being we
could drop some of the refactors if they are deemed not worth it.

Changelog:

v2->v3:
- rebase onto 6.3-rc1
- typedef a new type for mfill flags in patch 3/5 (suggested by Nadav)

v1->v2:
- refactor before adding the new flag, to avoid perpetuating messiness

Axel Rasmussen (5):
mm: userfaultfd: rename functions for clarity + consistency
mm: userfaultfd: don't pass around both mm and vma
mm: userfaultfd: combine 'mode' and 'wp_copy' arguments
mm: userfaultfd: don't separate addr + len arguments
mm: userfaultfd: add UFFDIO_CONTINUE_MODE_WP to install WP PTEs

fs/userfaultfd.c | 120 +++++-------
include/linux/hugetlb.h | 27 ++-
include/linux/shmem_fs.h | 9 +-
include/linux/userfaultfd_k.h | 61 +++---
include/uapi/linux/userfaultfd.h | 7 +
mm/hugetlb.c | 34 ++--
mm/shmem.c | 14 +-
mm/userfaultfd.c | 235 +++++++++++------------
tools/testing/selftests/mm/userfaultfd.c | 4 +
9 files changed, 247 insertions(+), 264 deletions(-)

--
2.40.0.rc0.216.gc4246ad0f0-goog