Re: [PATCH v5 0/2] Apple Magic Keyboard Backlight

From: Jiri Kosina
Date: Fri Mar 10 2023 - 09:37:07 EST


On Mon, 20 Feb 2023, Orlando Chamberlain wrote:

> This patchseries adds support for the internal keyboard backlight of
> Macs with Apple's "Magic" keyboard (MacBookPro16,* and MacBookAir9,1),
> and also documents what names should be used for keyboard backlight
> leds in Documentation/leds/well-known-leds.txt.
>
> v4->v5:
> - use <tab><space><space> for help in Kconfig
> - prepend "hid-" to filename in MAINTAINERS
>
> v3->v4:
> - collect reviews from Andy and Thomas
> - remove now unused hdev member of apple_magic_backlight
>
> v2->v3:
> - remove unneeded header inclusion
> - use s32 for report value type
> - remove unneeded null check
> - don't set drvdata as its never used
> - prepend "hid-" to module name
>
> v1->v2:
> - drop unneeded remove function
> - combine set functions
> - add missing header inclusions
> - avoid char as argument in favour of u8
> - handful of style/formatting fixes
> - use standard led name ":white:kbd_backlight"
> - rename USAGE_MAGIC_BL to HID_USAGE_MAGIC_BL
> - New patch documenting preferred keyboard backlight names
>
> v1: https://lore.kernel.org/linux-input/7D70F1FE-7F54-4D0A-8922-5466AA2AD364@xxxxxxxx/
> v2: https://lore.kernel.org/linux-input/20230216041224.4731-1-orlandoch.dev@xxxxxxxxx/
> v3: https://lore.kernel.org/linux-input/20230217102319.3419-1-orlandoch.dev@xxxxxxxxx/
> v4: https://lore.kernel.org/linux-input/20230218090709.7467-1-orlandoch.dev@xxxxxxxxx/
>
> Orlando Chamberlain (2):
> Documentation: leds: standardise keyboard backlight led names
> HID: hid-apple-magic-backlight: Add driver for keyboard backlight on
> internal Magic Keyboards
>
> Documentation/leds/well-known-leds.txt | 8 ++
> MAINTAINERS | 6 ++
> drivers/hid/Kconfig | 13 +++
> drivers/hid/Makefile | 1 +
> drivers/hid/hid-apple-magic-backlight.c | 120 ++++++++++++++++++++++++
> 5 files changed, 148 insertions(+)
> create mode 100644 drivers/hid/hid-apple-magic-backlight.c

Hi,

thanks for creating the support for backlight.

Is there any reason why not to fold all this into existing hid-apple? I
don't think we need separate driver for the backlist, separated from the
rest of hid-apple support.

Thanks,

--
Jiri Kosina
SUSE Labs