[PATCH v5 0/3] Simplify extcon_dev_register function.
From: Bumwoo Lee
Date: Sun Mar 19 2023 - 23:20:08 EST
It was modified to increase readability.
Changes from v4:
added null checking of edev on each function.
Chages from v3:
removed possibility of kfree(NULL).
Chages from v2:
resolved possible memory leak of dev->cables.
Changes from v1:
added return value handling.
Bumwoo Lee (3):
extcon: Add extcon_alloc_cables to simplify extcon register function
extcon: Add extcon_alloc_muex to simplify extcon register function
extcon: Add extcon_alloc_groups to simplify extcon register function
drivers/extcon/extcon.c | 281 +++++++++++++++++++++++-----------------
1 file changed, 165 insertions(+), 116 deletions(-)
--
2.35.1