[PATCH 5/5] soc: apple: mailbox: Rename config symbol to APPLE_MAILBOX

From: Hector Martin
Date: Tue Mar 28 2023 - 09:15:33 EST


With the original owner of APPLE_MAILBOX removed, let's rename the new
APPLE_MBOX to the old name. This avoids .config churn for downstream
users, and leaves us with an identical config symbol and module name as
before.

Signed-off-by: Hector Martin <marcan@xxxxxxxxx>
---
drivers/soc/apple/Kconfig | 5 ++---
drivers/soc/apple/Makefile | 2 +-
2 files changed, 3 insertions(+), 4 deletions(-)

diff --git a/drivers/soc/apple/Kconfig b/drivers/soc/apple/Kconfig
index d0e29bbd8c6f..c5203c388bf4 100644
--- a/drivers/soc/apple/Kconfig
+++ b/drivers/soc/apple/Kconfig
@@ -17,11 +17,10 @@ config APPLE_PMGR_PWRSTATE
controls for SoC devices. This driver manages them through the
generic power domain framework, and also provides reset support.

-config APPLE_MBOX
+config APPLE_MAILBOX
tristate "Apple SoC mailboxes"
depends on PM
depends on ARCH_APPLE || (64BIT && COMPILE_TEST)
- depends on !APPLE_MAILBOX
default ARCH_APPLE
help
Apple SoCs have various co-processors required for certain
@@ -33,7 +32,7 @@ config APPLE_MBOX

config APPLE_RTKIT
tristate "Apple RTKit co-processor IPC protocol"
- depends on APPLE_MBOX
+ depends on APPLE_MAILBOX
depends on ARCH_APPLE || COMPILE_TEST
default ARCH_APPLE
help
diff --git a/drivers/soc/apple/Makefile b/drivers/soc/apple/Makefile
index e52edf6a73da..20feee6f3943 100644
--- a/drivers/soc/apple/Makefile
+++ b/drivers/soc/apple/Makefile
@@ -1,7 +1,7 @@
# SPDX-License-Identifier: GPL-2.0-only
obj-$(CONFIG_APPLE_PMGR_PWRSTATE) += apple-pmgr-pwrstate.o

-obj-$(CONFIG_APPLE_MBOX) += apple-mailbox.o
+obj-$(CONFIG_APPLE_MAILBOX) += apple-mailbox.o
apple-mailbox-y = mailbox.o

obj-$(CONFIG_APPLE_RTKIT) += apple-rtkit.o

--
2.40.0