Re: [PATCH v1 12/14] extcon: Use sizeof(*pointer) instead of sizeof(type)

From: Chanwoo Choi
Date: Mon Apr 03 2023 - 10:32:21 EST


On 23. 3. 22. 23:40, Andy Shevchenko wrote:
> It is preferred to use sizeof(*pointer) instead of sizeof(type).
> The type of the variable can change and one needs not change
> the former (unlike the latter). No functional change intended.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> ---
> drivers/extcon/extcon.c | 17 ++++++-----------
> 1 file changed, 6 insertions(+), 11 deletions(-)
>
> diff --git a/drivers/extcon/extcon.c b/drivers/extcon/extcon.c
> index 0e04ea185c26..b3f038639cd6 100644
> --- a/drivers/extcon/extcon.c
> +++ b/drivers/extcon/extcon.c
> @@ -1099,9 +1099,7 @@ static int extcon_alloc_cables(struct extcon_dev *edev)
> if (!edev->max_supported)
> return 0;
>
> - edev->cables = kcalloc(edev->max_supported,
> - sizeof(struct extcon_cable),
> - GFP_KERNEL);
> + edev->cables = kcalloc(edev->max_supported, sizeof(*edev->cables), GFP_KERNEL);

Even if there are strictly not limitation of the number of maximum char
at the one line, But, I recommend to keep the 80 char at the one line
for the readability as following.

- edev->cables = kcalloc(edev->max_supported, sizeof(*edev->cables), GFP_KERNEL);
+ edev->cables = kcalloc(edev->max_supported,
+ sizeof(*edev->cables), GFP_KERNEL);


> if (!edev->cables)
> return -ENOMEM;
>
> @@ -1160,14 +1158,12 @@ static int extcon_alloc_muex(struct extcon_dev *edev)
> for (index = 0; edev->mutually_exclusive[index]; index++)
> ;
>
> - edev->attrs_muex = kcalloc(index + 1,
> - sizeof(struct attribute *),
> + edev->attrs_muex = kcalloc(index + 1, sizeof(*edev->attrs_muex),
> GFP_KERNEL);
> if (!edev->attrs_muex)
> return -ENOMEM;
>
> - edev->d_attrs_muex = kcalloc(index,
> - sizeof(struct device_attribute),
> + edev->d_attrs_muex = kcalloc(index, sizeof(*edev->d_attrs_muex),
> GFP_KERNEL);
> if (!edev->d_attrs_muex) {
> kfree(edev->attrs_muex);
> @@ -1213,8 +1209,8 @@ static int extcon_alloc_groups(struct extcon_dev *edev)
> return 0;
>
> edev->extcon_dev_type.groups = kcalloc(edev->max_supported + 2,
> - sizeof(struct attribute_group *),
> - GFP_KERNEL);
> + sizeof(*edev->extcon_dev_type.groups),
> + GFP_KERNEL);

ditto.

edev->extcon_dev_type.groups = kcalloc(edev->max_supported + 2,
- sizeof(*edev->extcon_dev_type.groups),
- GFP_KERNEL);
+ sizeof(*edev->extcon_dev_type.groups),
+ GFP_KERNEL);


> if (!edev->extcon_dev_type.groups)
> return -ENOMEM;
>
> @@ -1298,8 +1294,7 @@ int extcon_dev_register(struct extcon_dev *edev)
>
> spin_lock_init(&edev->lock);
> if (edev->max_supported) {
> - edev->nh = kcalloc(edev->max_supported, sizeof(*edev->nh),
> - GFP_KERNEL);
> + edev->nh = kcalloc(edev->max_supported, sizeof(*edev->nh), GFP_KERNEL);

- edev->nh = kcalloc(edev->max_supported, sizeof(*edev->nh), GFP_KERNEL);
+ edev->nh = kcalloc(edev->max_supported,
+ sizeof(*edev->nh), GFP_KERNEL);


> if (!edev->nh) {
> ret = -ENOMEM;
> goto err_alloc_nh;

--
Best Regards,
Samsung Electronics
Chanwoo Choi