Re: [PATCH 1/6] cgroup/cpuset: Rename functions dealing with DEADLINE accounting

From: Qais Yousef
Date: Tue Apr 04 2023 - 16:05:46 EST


On 03/29/23 14:55, Juri Lelli wrote:
> rebuild_root_domains() and update_tasks_root_domain() have neutral
> names, but actually deal with DEADLINE bandwidth accounting.
>
> Rename them to use 'dl_' prefix so that intent is more clear.
>
> No functional change.
>
> Suggested-by: Qais Yousef <qyousef@xxxxxxxxxxx>
> Signed-off-by: Juri Lelli <juri.lelli@xxxxxxxxxx>
> ---

Reviewed-by: Qais Yousef <qyousef@xxxxxxxxxxx>
Tested-by: Qais Yousef <qyousef@xxxxxxxxxxx>


Thanks!

--
Qais Yousef

> kernel/cgroup/cpuset.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/kernel/cgroup/cpuset.c b/kernel/cgroup/cpuset.c
> index 636f1c682ac0..501913bc2805 100644
> --- a/kernel/cgroup/cpuset.c
> +++ b/kernel/cgroup/cpuset.c
> @@ -1066,7 +1066,7 @@ static int generate_sched_domains(cpumask_var_t **domains,
> return ndoms;
> }
>
> -static void update_tasks_root_domain(struct cpuset *cs)
> +static void dl_update_tasks_root_domain(struct cpuset *cs)
> {
> struct css_task_iter it;
> struct task_struct *task;
> @@ -1079,7 +1079,7 @@ static void update_tasks_root_domain(struct cpuset *cs)
> css_task_iter_end(&it);
> }
>
> -static void rebuild_root_domains(void)
> +static void dl_rebuild_rd_accounting(void)
> {
> struct cpuset *cs = NULL;
> struct cgroup_subsys_state *pos_css;
> @@ -1107,7 +1107,7 @@ static void rebuild_root_domains(void)
>
> rcu_read_unlock();
>
> - update_tasks_root_domain(cs);
> + dl_update_tasks_root_domain(cs);
>
> rcu_read_lock();
> css_put(&cs->css);
> @@ -1121,7 +1121,7 @@ partition_and_rebuild_sched_domains(int ndoms_new, cpumask_var_t doms_new[],
> {
> mutex_lock(&sched_domains_mutex);
> partition_sched_domains_locked(ndoms_new, doms_new, dattr_new);
> - rebuild_root_domains();
> + dl_rebuild_rd_accounting();
> mutex_unlock(&sched_domains_mutex);
> }
>
> --
> 2.39.2
>