global_reclaim() and code documentation (was: Re: [PATCH v3 3/3] mm: vmscan: ignore non-LRU-based reclaim in memcg reclaim

From: Johannes Weiner
Date: Wed Apr 05 2023 - 16:02:40 EST


On Fri, Mar 31, 2023 at 12:30:11AM -0700, Yosry Ahmed wrote:
> On Fri, Mar 31, 2023 at 12:25 AM Yu Zhao <yuzhao@xxxxxxxxxx> wrote:
> > On Fri, Mar 31, 2023 at 1:08 AM Yosry Ahmed <yosryahmed@xxxxxxxxxx> wrote:
> >
> > ...
> >
> > > diff --git a/mm/vmscan.c b/mm/vmscan.c
> > > index a3e38851b34ac..bf9d8e175e92a 100644
> > > --- a/mm/vmscan.c
> > > +++ b/mm/vmscan.c
> > > @@ -533,7 +533,35 @@ EXPORT_SYMBOL(mm_account_reclaimed_pages);
> > > static void flush_reclaim_state(struct scan_control *sc,
> > > struct reclaim_state *rs)
> > > {
> > > - if (rs) {
> > > + /*
> > > + * Currently, reclaim_state->reclaimed includes three types of pages
> > > + * freed outside of vmscan:
> > > + * (1) Slab pages.
> > > + * (2) Clean file pages from pruned inodes.
> > > + * (3) XFS freed buffer pages.
> > > + *
> > > + * For all of these cases, we have no way of finding out whether these
> > > + * pages were related to the memcg under reclaim. For example, a freed
> > > + * slab page could have had only a single object charged to the memcg
> > > + * under reclaim. Also, populated inodes are not on shrinker LRUs
> > > + * anymore except on highmem systems.
> > > + *
> > > + * Instead of over-reporting the reclaimed pages in a memcg reclaim,
> > > + * only count such pages in system-wide reclaim. This prevents
> > > + * unnecessary retries during memcg charging and false positive from
> > > + * proactive reclaim (memory.reclaim).
> >
> > What happens when writing to the root memory.reclaim?
> >
> > > + *
> > > + * For uncommon cases were the freed pages were actually significantly
> > > + * charged to the memcg under reclaim, and we end up under-reporting, it
> > > + * should be fine. The freed pages will be uncharged anyway, even if
> > > + * they are not reported properly, and we will be able to make forward
> > > + * progress in charging (which is usually in a retry loop).
> > > + *
> > > + * We can go one step further, and report the uncharged objcg pages in
> > > + * memcg reclaim, to make reporting more accurate and reduce
> > > + * under-reporting, but it's probably not worth the complexity for now.
> > > + */
> > > + if (rs && !cgroup_reclaim(sc)) {
> >
> > To answer the question above, global_reclaim() would be preferred.
>
> Great point, global_reclaim() is fairly recent. I didn't see it
> before. Thanks for pointing it out. I will change it for v4 -- will
> wait for more feedback before respinning.

I didn't realize it came back, I deleted it a while ago:

commit b5ead35e7e1d3434ce436dfcb2af32820ce54589
Author: Johannes Weiner <hannes@xxxxxxxxxxx>
Date: Sat Nov 30 17:55:40 2019 -0800

mm: vmscan: naming fixes: global_reclaim() and sane_reclaim()

Seven years after introducing the global_reclaim() function, I still have
to double take when reading a callsite. I don't know how others do it,
this is a terrible name.

Invert the meaning and rename it to cgroup_reclaim().

Could you shed some light on why it was brought back? It's not clear
to me from the changelog in a579086c99ed70cc4bfc104348dbe3dd8f2787e6.

We also now have this:

static bool cgroup_reclaim(struct scan_control *sc)
{
return sc->target_mem_cgroup;
}

static bool global_reclaim(struct scan_control *sc)
{
return !sc->target_mem_cgroup || mem_cgroup_is_root(sc->target_mem_cgroup);
}

The name suggests it's the same thing twice, with opposite
polarity. But of course they're subtly different, and not documented.

When do you use which?