Re: [PATCH v8 2/8] dt-bindings: phy: qcom,qmp-usb: Add IPQ9574 USB3 PHY

From: Krzysztof Kozlowski
Date: Thu Apr 06 2023 - 03:42:50 EST


On 05/04/2023 13:41, Varadarajan Narayanan wrote:
> Add dt-bindings for USB3 PHY found on Qualcomm IPQ9574
>
> Signed-off-by: Varadarajan Narayanan <quic_varada@xxxxxxxxxxx>
> ---
> Changes in v8:
> - Update clock names for ipq9574
>
> Changes in v6:
> - Made power-domains optional
>
> Note: In the earlier patch sets, had used the (legacy)
> specification available in qcom,msm8996-qmp-usb3-phy.yaml. Moved
> to newer specification in qcom,sc8280xp-qmp-usb3-uni-phy.yaml
> ---
> .../phy/qcom,sc8280xp-qmp-usb3-uni-phy.yaml | 43 +++++++++++++++++++---
> 1 file changed, 37 insertions(+), 6 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/phy/qcom,sc8280xp-qmp-usb3-uni-phy.yaml b/Documentation/devicetree/bindings/phy/qcom,sc8280xp-qmp-usb3-uni-phy.yaml
> index 16fce10..e902a0d 100644
> --- a/Documentation/devicetree/bindings/phy/qcom,sc8280xp-qmp-usb3-uni-phy.yaml
> +++ b/Documentation/devicetree/bindings/phy/qcom,sc8280xp-qmp-usb3-uni-phy.yaml
> @@ -16,6 +16,7 @@ description:
> properties:
> compatible:
> enum:
> + - qcom,ipq9574-qmp-usb3-phy
> - qcom,sc8280xp-qmp-usb3-uni-phy
>
> reg:
> @@ -25,11 +26,7 @@ properties:
> maxItems: 4
>
> clock-names:
> - items:
> - - const: aux
> - - const: ref
> - - const: com_aux
> - - const: pipe
> + maxItems: 4
>
> power-domains:
> maxItems: 1
> @@ -60,7 +57,6 @@ required:
> - reg
> - clocks
> - clock-names
> - - power-domains
> - resets
> - reset-names
> - vdda-phy-supply
> @@ -71,6 +67,41 @@ required:
>
> additionalProperties: false
>
> +allOf:

As you can see in example-schema, allOf goes before
additionalProperties: false.

> + - if:
> + properties:
> + compatible:
> + contains:
> + enum:
> + - qcom,ipq9574-qmp-usb3-phy
> + then:
> + properties:
> + clocks:
> + maxItems: 4

Don't need clocks here.

> + clock-names:
> + items:
> + - const: aux
> + - const: ref
> + - const: cfg_ahb
> + - const: pipe
> +
> + - if:
> + properties:
> + compatible:
> + contains:
> + enum:
> + - qcom,sc8280xp-qmp-usb3-uni-phy
> + then:
> + properties:
> + clocks:
> + maxItems: 4

Neither here.

> + clock-names:
> + items:
> + - const: aux
> + - const: ref
> + - const: com_aux

Can anyone explain me why do we name these (here and other Qualcomm
bindings) based on clock name, not input? Just because different clock
is fed to the block, does not necessarily mean the input should be named
differently.

> + - const: pipe
> +
> examples:
> - |
> #include <dt-bindings/clock/qcom,gcc-sc8280xp.h>

Best regards,
Krzysztof