On 2023/4/7 10:30, Youling Tang wrote:
/* snip */
diff --git a/arch/loongarch/kernel/kprobes.c
b/arch/loongarch/kernel/kprobes.c
index 08c78d2..a5c3712 100644
--- a/arch/loongarch/kernel/kprobes.c
+++ b/arch/loongarch/kernel/kprobes.c
@@ -4,19 +4,8 @@
#include <linux/preempt.h>
#include <asm/break.h>
-static const union loongarch_instruction breakpoint_insn = {
- .reg0i15_format = {
- .opcode = break_op,
- .immediate = BRK_KPROBE_BP,
- }
-};
-
-static const union loongarch_instruction singlestep_insn = {
- .reg0i15_format = {
- .opcode = break_op,
- .immediate = BRK_KPROBE_SSTEPBP,
- }
-};
+#define breakpoint_insn larch_insn_gen_break(BRK_KPROBE_BP)
+#define singlestep_insn larch_insn_gen_break(BRK_KPROBE_SSTEPBP)
IMO, Defined as KPROBE_BP_INSN, KPROBE_SSTEPBP_INSN may be better.
Are you suggesting to hardcode the instruction words for those two BREAK
flavors?
I don't think it's better because even more structured info is
lost, and the compiler would generate the same code (if not, it's the
compiler that's to be fixed).
Actually, I don't know why this commit was necessary in the first place.
For the very least, it consisted of two logical changes (pass around
instruction words instead of unions; and change the BREAK insns to make
them words) that should get split;
but again, the generated code should
be identical anyway, so it seems a lot of churn for no benefit and
reduced readability.