Cannot boot an i386-UEFI thinkpad lenovo tablet-2

From: Corentin Labbe
Date: Tue May 09 2023 - 02:30:02 EST


I have an old i386 lenovo thinpad tablet-2 currently windows 8.
After disabling secure boot, I tried to install a Linux on it but all my tries fail.
Grub is loading correclty.
Memtest86 run on it without problem.
( I also tried some BSD but since it is an i386 UEFI only, no BSD seems to support this)

But the Linux kernel fail to boot on it, black screen (in case of debian installer, the screen is stuck with the install choice), no more info.
Since this is a tablet, there are no ethernet port. (I wanted to boot it blindly)
The bios speak about a debug port, but I found nothing which seems a physical debug port output.
I tried to wire the microusb power port on a USB host, but the host fail to enumerate any device (I tried also a spetial USB cable with data/power separated to be sure the problem was not the host failling to give enough power)

The tablet has only one port, so I use a hub for keyboard and USB key.
Immediatly after booting Linux, all hub port light goes to off.

I tried different own made kernel with different choice about CONFIG_FB, selecting all INTEL options, etc... no change
I tried to change video resolution via vga=ask or video=640x480 but no change.

Any clue on how debug further ?