Re: [PATCH net-next 24/30] net: dsa: mt7530: rename MT7530_MFC to MT753X_MFC
From: Vladimir Oltean
Date: Fri May 26 2023 - 11:43:09 EST
On Mon, May 22, 2023 at 03:15:26PM +0300, arinc9.unal@xxxxxxxxx wrote:
> /* Disable flooding on all ports */
> - mt7530_clear(priv, MT7530_MFC, BC_FFP_MASK | UNM_FFP_MASK |
> - UNU_FFP_MASK);
> + mt7530_clear(priv, MT753X_MFC, MT753X_BC_FFP_MASK | MT753X_UNM_FFP_MASK
> + | MT753X_UNU_FFP_MASK);
The preferred coding style is not to start new lines with operators.
> +/* Register for CPU forward control */
> #define MT7531_CFC 0x4
> #define MT7531_MIRROR_EN BIT(19)
> -#define MT7531_MIRROR_MASK (MIRROR_MASK << 16)
> -#define MT7531_MIRROR_PORT_GET(x) (((x) >> 16) & MIRROR_MASK)
> -#define MT7531_MIRROR_PORT_SET(x) (((x) & MIRROR_MASK) << 16)
> +#define MT7531_MIRROR_MASK (0x7 << 16)
minor nitpick: if you express this as GENMASK(18, 16), it will be a bit
easier to cross-check with the datasheet, since both 18 and 16 are more
representative than 0x7.
> +#define MT7531_MIRROR_PORT_GET(x) (((x) >> 16) & 0x7)
also here: (((x) & GENMASK(18, 16)) >> 16)
> +#define MT7531_MIRROR_PORT_SET(x) (((x) & 0x7) << 16)
and here: (((x) << 16) & GENMASK(18, 16))