Re: [RFC][PATCH 2/2] sched: Use fancy new guards

From: Miguel Ojeda
Date: Fri May 26 2023 - 13:41:47 EST

On Fri, May 26, 2023 at 7:08 PM Kees Cook <keescook@xxxxxxxxxxxx> wrote:
> > FWIW C++ has std::scoped_lock. So perhaps using a similar wording may help ?
> Yeah, I like "scoped_*" and "guarded_*" for naming. IMO, it reads better.

FWIW in the Rust side we called the general facility `ScopeGuard`,
then we also have lock `Guard`s and Rust stdlib has things like