Re: [regression] Since kernel 6.3.1 logitech unify receiver not working properly

From: Thorsten Leemhuis
Date: Sun May 28 2023 - 08:29:05 EST

On 26.05.23 20:41, Jiri Kosina wrote:
> On Thu, 25 May 2023, Jiri Kosina wrote:
>>>>> That bug is pre-existing (ie the problem was not introduced by that
>>>>> commit), but who knows if the retry makes things worse (ie if it then
>>>>> triggers on a retry, the response data will be the *previous* response).
>>>>> The whole "goto exit" games should be removed too, because we're in a
>>>>> for-loop, and instead of "goto exit" it should just do "break".
>>>>> IOW, something like this might be worth testing.
>>>>> That said, while I think the code is buggy, I doubt this is the actual
>>>>> cause of the problem people are reporting. But it would be lovely to
>>>>> hear if the attached patch makes any difference, and I think this is
>>>>> fixing a real - but unlikely - problem anyway.
>>> FWIW, Linus, your patch is
>>> Reviewed-by: Benjamin Tissoires <benjamin.tissoires@xxxxxxxxxx>
>>> Feel free to submit it to us or to apply it directly if you prefer as
>>> this is clearly a fix for a code path issue.
>> It would be nice to hear from the people who were able to reproduce the
>> issue whether this makes any observable difference in behavior though. I
>> don't currently think it would, as it fixes a potential NULL pointer
>> dereference, which is not what has been reported.
>> Has anyone of the affected people tried to bisect the issue?
> Could anyone

Reminder: a lot of the affected users can only be reached through the
bugzilla ticket ( )
that made me start this thread. Sorry for this mess, but I can't simply
CC them because on account creation users are told that the "email
address will never be displayed to logged out users". Bugbot will
hopefully soon make this sort of problems history.

> who is able to reproduce the issue please check whether
> reverting
> 586e8fede7953b16 ("HID: logitech-hidpp: Retry commands when device is busy")
> has any observable effect?

See and later –
it at least solved the problem for one user.

But it's all a mess (at least afaics). Earlier in that ticket some other
user said things work with 6.4-rc kernel, while for another confirmed
things are still broken. So maybe we deal with more than one problem. Or
testing went sideways for some of the users.

Ciao, Thorsten