Re: [PATCH 1/4] staging: rtl8192e: Rename variable SetWirelessMode

From: Greg Kroah-Hartman
Date: Sun May 28 2023 - 12:08:17 EST


On Sun, May 28, 2023 at 08:21:33PM +0530, Yogesh Hegde wrote:
> Rename variable SetWirelessMode to set_wireless_mode to avoid
> CamelCase which is not accepted by checkpatch.
>
> Signed-off-by: Yogesh Hegde <yogi.kernel@xxxxxxxxx>
> ---
> drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 2 +-
> drivers/staging/rtl8192e/rtllib.h | 2 +-
> drivers/staging/rtl8192e/rtllib_softmac.c | 12 ++++++------
> 3 files changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
> index 17b70dde7eeb..699c4accf2db 100644
> --- a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
> +++ b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
> @@ -716,7 +716,7 @@ static void _rtl92e_init_priv_handler(struct net_device *dev)
> priv->rtllib->check_nic_enough_desc = _rtl92e_check_nic_enough_desc;
> priv->rtllib->handle_assoc_response = _rtl92e_handle_assoc_response;
> priv->rtllib->handle_beacon = _rtl92e_handle_beacon;
> - priv->rtllib->SetWirelessMode = rtl92e_set_wireless_mode;
> + priv->rtllib->set_wireless_mode = rtl92e_set_wireless_mode;

As this is only set in one place, why is it needed at all? Why not just
call the real function instead?

Same for the other patches in this series, why not turn this into a set
of cleanup patches removing the unnecessary indirection and removing the
CamelCase variables entirely?

thanks,

greg k-h