Re: [PATCH v2 1/2] soc: hisilicon: Support HCCS driver on Kunpeng SoC

From: lihuisong (C)
Date: Tue May 30 2023 - 06:57:57 EST

在 2023/5/30 16:43, Sudeep Holla 写道:
On Tue, May 30, 2023 at 10:53:38AM +0800, lihuisong (C) wrote:
Hi Sudeep,

在 2023/5/25 16:12, lihuisong (C) 写道:
在 2023/5/25 15:35, Sudeep Holla 写道:
On Thu, May 25, 2023 at 10:41:51AM +0800, lihuisong (C) wrote:
Hi Sudeep,

Here, the interface is used to determine whether a port is in use or
If we just use 'status', it cannot inidicates its own meaning by name.
What do you think?

How about "port_status" or "port-status" ?
The meaning of this status is a little board.
How about 'enable'? just a read-only entry.

"using_status" --> "enable" ? What do you think?
Its original purpose was to determine whether a port is in use or enabled.

That's fine. The main point I was trying to make is plain "status" or
ok, create it as "enable".
"using_status" is prone to conflict as you have ports, lanes, ...etc.
Adding "port_" to the name whatever you choose is better.
Yes, adding "port_" is better if not all sysfs entries are related to the port.
Actually, all sysfs entries belong to the hccsX port under the hccsX directory.