Re: [PATCH 1/2] media: dt-bindings: alvium: add document YAML binding

From: Tommaso Merciai
Date: Wed May 31 2023 - 05:44:06 EST


Hello Krzysztof,

On Tue, May 30, 2023 at 05:52:17PM +0200, Krzysztof Kozlowski wrote:
> On 26/05/2023 12:34, Tommaso Merciai wrote:
> > Add documentation of device tree in YAML schema for the ALVIUM
> > Camera from Allied Vision Inc.
> >
>
> Thank you for your patch. There is something to discuss/improve.
>
>
> > References:
> > - https://www.alliedvision.com/en/products/embedded-vision-solutions
> >
> > Signed-off-by: Tommaso Merciai <tomm.merciai@xxxxxxxxx>
> > ---
> > .../media/i2c/alliedvision,alvium.yaml | 117 ++++++++++++++++++
> > 1 file changed, 117 insertions(+)
> > create mode 100644 Documentation/devicetree/bindings/media/i2c/alliedvision,alvium.yaml
> >
> > diff --git a/Documentation/devicetree/bindings/media/i2c/alliedvision,alvium.yaml b/Documentation/devicetree/bindings/media/i2c/alliedvision,alvium.yaml
> > new file mode 100644
> > index 000000000000..5385fe849ffd
> > --- /dev/null
> > +++ b/Documentation/devicetree/bindings/media/i2c/alliedvision,alvium.yaml
> > @@ -0,0 +1,117 @@
> > +# SPDX-License-Identifier: GPL-2.0
>
> Dual license please.
>
> Please run scripts/checkpatch.pl and fix reported warnings. Some
> warnings can be ignored, but the code here looks like it needs a fix.
> Feel free to get in touch if the warning is not clear.
>
> It does not look like you tested the bindings, at least after quick
> look. Please run `make dt_binding_check` (see
> Documentation/devicetree/bindings/writing-schema.rst for instructions).
> Maybe you need to update your dtschema and yamllint.
>
> > +%YAML 1.2
> > +---
> > +$id: http://devicetree.org/schemas/media/i2c/alliedvision,alvium.yaml#
> > +$schema: http://devicetree.org/meta-schemas/core.yaml#
> > +
> > +title: Alliedvision Alvium Camera
> > +
> > +maintainers:
> > + - Tommaso Merciai <tomm.merciai@xxxxxxxxx>
> > + - Martin Hecht <martin.hecht@xxxxxxxx>
> > +
> > +allOf:
> > + - $ref: /schemas/media/video-interface-devices.yaml#
> > +
> > +properties:
> > + compatible:
> > + const: alliedvision,alvium
>
> Missing vendor prefix in vendor-prefixes.yaml
>
> > +
> > + reg:
> > + maxItems: 1
> > +
> > + clocks:
> > + description: XCLK Input Clock
>
> maxItems: 1
>
> > +
> > + clock-names:
> > + const: xclk
>
> Drop names, useless for one entry with generic name.
>
> > +
> > + powerdown-gpios:
> > + maxItems: 1
> > + description: >
> > + Reference to the GPIO connected to the powerdown pin, if any.
>
> Drop description, it's obvious.
>
> > +
> > + reset-gpios:
> > + maxItems: 1
> > + description: >
> > + Reference to the GPIO connected to the reset pin, if any.
>
> Drop description, it's obvious.
>
>
> > +
> > + streamon-delay:
> > + maxItems: 1
> > + description: >
> > + Delay before camera start capturing frames in us.
>
> Missing vendor prefix (unless it is a common property), missing units
> suffix in property name (-us). It's not a list. Why this should be a
> hardware property?
>
> > +
> > + rotation:
> > + enum:
> > + - 0
> > + - 180
> > +
> > + port:
> > + description: Digital Output Port
> > + $ref: /schemas/graph.yaml#/$defs/port-base
> > + additionalProperties: false
> > +
> > + properties:
> > + endpoint:
> > + $ref: /schemas/media/video-interfaces.yaml#
> > + unevaluatedProperties: false
> > +
> > + properties:
> > + clock-lanes:
> > + const: 0
>
> Blank line
>
> > + data-lanes:
> > + minItems: 1
> > + maxItems: 4
>
> Four items and each 1 or 4? so <4>, <1>, and what else? Please provide
> example for this.
>
> > + items:
> > + enum: [1, 4]
> > + link-frequencies: true
>
> Drop this one, should not be needed.
>
> > +
> > + required:
> > + - data-lanes
> > + - link-frequencies
> > +
> > +required:
> > + - compatible
> > + - reg
> > + - clocks
> > + - clock-names
> > + - port
> > +
> > +additionalProperties: false
> > +
> > +examples:
> > + - |
> > + #include <dt-bindings/clock/imx6qdl-clock.h>
> > + #include <dt-bindings/gpio/gpio.h>
>
> Use 4 spaces for example indentation. Not 6.
>
> > +
> > + i2c {
> > + #address-cells = <1>;
> > + #size-cells = <0>;
> > +
> > + camera: alvium@3c {
>
> Node names should be generic. See also explanation and list of examples
> in DT specification:
> https://devicetree-specification.readthedocs.io/en/latest/chapter2-devicetree-basics.html#generic-names-recommendation
>
> > + compatible = "alliedvision,alvium";
> > + reg = <0x3c>;
> > + pinctrl-names = "default";
> > + pinctrl-0 = <&pinctrl_csi0_pwn>, <&pinctrl_csi0_rst>, <&pinctrl_csi_mclk>;
> > + clocks = <&clk IMX8MP_CLK_IPP_DO_CLKO2>;
> > + clock-names = "xclk";
> > + assigned-clocks = <&clk IMX8MP_CLK_IPP_DO_CLKO2>;
> > + assigned-clock-parents = <&clk IMX8MP_CLK_24M>;
> > + assigned-clock-rates = <24000000>;
> > + streamon-delay = <20>;
> > + powerdown-gpios = <&gpio2 11 GPIO_ACTIVE_HIGH>;
> > + reset-gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
> > + status = "okay";
>
> Drop status
>
> > +
> > + port {
> > + alvium_out: endpoint {
> > + remote-endpoint = <&mipi_csi_0_in>;
> > + data-lanes = <1 2 3 4>;
>
> OK, here is the example. You did not test it.

Thanks for your review.
I miss this on v2, mb.
I'll apply your hints on v3.

Regards,
Tommaso


>
>
>
> Best regards,
> Krzysztof
>