Re: [PATCH net-next v2 03/10] net: phy: introduce phy_is_c45()

From: Andrew Lunn
Date: Fri Jun 23 2023 - 13:15:36 EST


On Fri, Jun 23, 2023 at 12:29:12PM +0200, Michael Walle wrote:
> Provide a helper to determine if the PHY is a C45 one. This is a
> preparation patch to remove the is_c45 field. No functional change.

Part of the problem you are addressing in this patchset is the mix up
between the c45 register space and the access method to the c45
register space.

> +static inline bool phy_is_c45(struct phy_device *phydev)
> +{
> + return phydev->is_c45;
> +}

This helper, in the end, is about c45 registers. It is a bit wordy,
but how about calling it phy_has_c45_registers()?

Andrew