Re: [RESEND PATCH v3 00/11] mtd: spi-nor: spansion: Add support for Infineon S28HS02GT

From: Takahiro Kuwano
Date: Wed Jul 26 2023 - 00:27:46 EST


Hi Tudor,

I tested all SEMPER flash devices below.
S25FS256T
S25HS512T, S25HL512T, S25HS01GT, S25HL01GT
S25HS02GT, S25HL02GT
S28HS512T, S28HL512T, S28HS01GT, S28HL01GT
S28HS02GT

As I sent another email, S25FS256T failed due to SCCR map.
All other devices are OK.


Now we can remove these macros as we use vreg_offset.

#define SPINOR_REG_CYPRESS_CFR1V \
(SPINOR_REG_CYPRESS_VREG + SPINOR_REG_CYPRESS_CFR1)

#define SPINOR_REG_CYPRESS_CFR3V \
(SPINOR_REG_CYPRESS_VREG + SPINOR_REG_CYPRESS_CFR3)

#define SPINOR_REG_CYPRESS_CFR5V \
(SPINOR_REG_CYPRESS_VREG + SPINOR_REG_CYPRESS_CFR5)

Thanks,
Takahiro


On 7/24/2023 5:12 PM, Tudor Ambarus wrote:
> Resending as patch 10/11 and 11/11 were not sent.
>
> Takahiro, since you already have to test all these flashes, I took the
> liberty and added some other changes that would be good to have. The
> first one lets SFDP determine the flash size and sector size. Michael is
> in the process of changing how INFO is handled, we'd like to get rid of
> these params when SFDP tables are defined. The other 2 patches
> consolidates a bit the spansion code with the idea that we should use
> the same code paths for both single (SCP) and multi chip package (MCP)
> flashes were possible. We avoid this way code duplication and have
> better test coverage on the code. On your patches I modified how/where
> "if (!params->n_dice || !params->vreg_offset)" is handled. Please review
> all and if you agree with the changes, retest on all flashes. Everything
> looks good to me, if the tests pass, I'll queue all.
>
> Cheers,
> ta
>
>
> Takahiro Kuwano (8):
> mtd: spi-nor: spansion: use CLPEF as an alternative to CLSR
> mtd: spi-nor: spansion: preserve CFR2V[7] when writing MEMLAT
> mtd: spi-nor: spansion: prepare octal dtr methods for multi chip
> support
> mtd: spi-nor: spansion: switch set_octal_dtr method to use vreg_offset
> mtd: spi-nor: spansion: switch h28hx's ready() to use vreg_offset
> mtd: spi-nor: spansion: add MCP support in set_octal_dtr()
> mtd: spi-nor: spansion: add octal DTR support in RD_ANY_REG_OP
> mtd: spi-nor: spansion: add support for S28HS02GT
>
> Tudor Ambarus (3):
> mtd: spi-nor: spansion: let SFDP determine the flash and sector size
> mtd: spi-nor: spansion: switch s25hx_t to use vreg_offset for
> quad_enable()
> mtd: spi-nor: spansion: switch cypress_nor_get_page_size() to use
> vreg_offset
>
> drivers/mtd/spi-nor/atmel.c | 8 +-
> drivers/mtd/spi-nor/core.c | 23 ++-
> drivers/mtd/spi-nor/core.h | 4 +-
> drivers/mtd/spi-nor/issi.c | 4 +-
> drivers/mtd/spi-nor/macronix.c | 4 +-
> drivers/mtd/spi-nor/micron-st.c | 4 +-
> drivers/mtd/spi-nor/spansion.c | 294 +++++++++++++++++++++-----------
> drivers/mtd/spi-nor/sst.c | 8 +-
> drivers/mtd/spi-nor/winbond.c | 4 +-
> drivers/mtd/spi-nor/xilinx.c | 4 +-
> 10 files changed, 239 insertions(+), 118 deletions(-)
>