RE: [PATCH v2 06/12] iommu: Make dev->fault_param static

From: Tian, Kevin
Date: Thu Aug 03 2023 - 23:56:47 EST


> From: Baolu Lu <baolu.lu@xxxxxxxxxxxxxxx>
> Sent: Friday, August 4, 2023 11:17 AM
>
> On 2023/8/3 16:08, Tian, Kevin wrote:
> >> From: Lu Baolu <baolu.lu@xxxxxxxxxxxxxxx>
> >> Sent: Thursday, July 27, 2023 1:49 PM
> >>
> >>
> >> mutex_init(&param->lock);
> >> + param->fault_param = kzalloc(sizeof(*param->fault_param),
> >> GFP_KERNEL);
> >> + if (!param->fault_param) {
> >> + kfree(param);
> >> + return -ENOMEM;
> >> + }
> >> + mutex_init(&param->fault_param->lock);
> >> + INIT_LIST_HEAD(&param->fault_param->faults);
> >
> > let's also move 'partial' from struct iopf_device_param into struct
> > iommu_fault_param. That logic is not specific to sva.
> >
> > meanwhile probably iopf_device_param can be renamed to
> > iopf_sva_param since all the remaining fields are only used by
> > the sva handler.
> >
> > current naming (iommu_fault_param vs. iopf_device_param) is a
> > bit confusing when reading related code.
>
> My understanding is that iommu_fault_param is for all kinds of iommu
> faults. Currently they probably include recoverable IO page faults or
> unrecoverable DMA faults.
>
> While, iopf_device_param is for the recoverable IO page faults. I agree
> that this naming is not specific and even confusing. Perhaps renaming it
> to something like iommu_iopf_param?
>

or just iopf_param...