Re: [RFC PATCH] gpio: consumer: new virtual driver

From: Bartosz Golaszewski
Date: Mon Aug 07 2023 - 15:47:41 EST


On Fri, Aug 4, 2023 at 9:58 PM Andy Shevchenko
<andriy.shevchenko@xxxxxxxxxxxxxxx> wrote:
>
> On Fri, Aug 04, 2023 at 06:03:47PM +0200, Bartosz Golaszewski wrote:
> > On Thu, Aug 3, 2023 at 1:39 PM Andy Shevchenko
> > <andriy.shevchenko@xxxxxxxxxxxxxxx> wrote:
>
> ...
>
> > > > + if (list_empty(&dev->lookup_list))
> > > > + return -ENODATA;
> > >
> > > Instead you may count nodes here and if 0, return an error, otherwise pass it
> > > to the callee.
> >
> > I'm not following, please rephrase.
>
> The below call calls list_count_nodes(), you may simply join these two checks
> by calling list_count_nodes() and return -ENODATA in case it's 0.
>

We don't gain anything by doing that: list_empty() doesn't count
nodes, it just checks the head pointer. We would decrease readability
(more arguments!) for no reason.

Bart

> > > > + swnode = gpio_consumer_make_device_swnode(dev);
> > > > + if (IS_ERR(swnode))
> > > > + return PTR_ERR(swnode);
>
> ...
>
> > > > + if ((!live && !gpio_consumer_device_is_live_unlocked(dev)) ||
> > > > + (live && gpio_consumer_device_is_live_unlocked(dev)))
> > >
> > > if (live ^ gpio_consumer_device_is_live_unlocked(dev))
> > >
> > > ?
> >
> > Nah, let's not use bitwise operators for boolean logic.
>
> Then it's even simpler:
>
> if (live == gpio_consumer_device_is_live_unlocked(dev))
>
> --
> With Best Regards,
> Andy Shevchenko
>
>