Re: [PATCH] uapi/netfilter: Change netfilter hook verdict code definition from macro to enum

From: David Wang
Date: Tue Sep 05 2023 - 16:49:18 EST




At 2023-09-06 00:38:02, "Daniel Xu" <dxu@xxxxxxxxx> wrote:
>Hi David,
>
>On Mon, Sep 04, 2023 at 09:02:02PM +0800, David Wang wrote:

>> #include <linux/in6.h>
>>
>> /* Responses from hook functions. */
>> -#define NF_DROP 0
>> -#define NF_ACCEPT 1
>> -#define NF_STOLEN 2
>> -#define NF_QUEUE 3
>> -#define NF_REPEAT 4
>> -#define NF_STOP 5 /* Deprecated, for userspace nf_queue compatibility. */
>> -#define NF_MAX_VERDICT NF_STOP
>> +enum {
>> + NF_DROP = 0,
>> + NF_ACCEPT = 1,
>> + NF_STOLEN = 2,
>> + NF_QUEUE = 3,
>> + NF_REPEAT = 4,
>> + NF_STOP = 5, /* Deprecated, for userspace nf_queue compatibility. */
>> + NF_MAX_VERDICT = NF_STOP,
>> +};
>
>Switching from macro to enum works for almost all use cases, but not
>all. If someone if #ifdefing the symbols (which is plausible) this
>change would break them.
>
>I think I've seen some other networking code define both enums and
>macros. But it was a little ugly. Not sure if that is acceptable here or
>not.
>
>[...]
>
>Thanks,
>Daniel


Thanks for the review~
I do not have a strong reasoning to deny the possibility of breaking unexpected usage of this macros,

but I also agree that it is ugly to use both enum and macro at the same time.

Kind of don't know how to proceed from here now...