Re: [RFC PATCH v2 12/35] ACPI: Use the acpi_device_is_present() helper in more places

From: Jonathan Cameron
Date: Thu Sep 14 2023 - 08:05:03 EST


On Wed, 13 Sep 2023 16:38:00 +0000
James Morse <james.morse@xxxxxxx> wrote:

> acpi_device_is_present() checks the present or functional bits
> from the cached copy of _STA.
>
> A few places open-code this check. Use the helper instead to
> improve readability.
>
> Signed-off-by: James Morse <james.morse@xxxxxxx>

Reviewed-by: Jonathan Cameron <Jonathan.Cameron@xxxxxxxxxx>

Pull this one out and send it upstream in advance of the rest.

Jonathan


> ---
> drivers/acpi/scan.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
> index 691d4b7686ee..ed01e19514ef 100644
> --- a/drivers/acpi/scan.c
> +++ b/drivers/acpi/scan.c
> @@ -304,7 +304,7 @@ static int acpi_scan_device_check(struct acpi_device *adev)
> int error;
>
> acpi_bus_get_status(adev);
> - if (adev->status.present || adev->status.functional) {
> + if (acpi_device_is_present(adev)) {
> /*
> * This function is only called for device objects for which
> * matching scan handlers exist. The only situation in which
> @@ -338,7 +338,7 @@ static int acpi_scan_bus_check(struct acpi_device *adev, void *not_used)
> int error;
>
> acpi_bus_get_status(adev);
> - if (!(adev->status.present || adev->status.functional)) {
> + if (!acpi_device_is_present(adev)) {
> acpi_scan_device_not_present(adev);
> return 0;
> }