Re: [PATCH v1 06/13] thermal: gov_fair_share: Rearrange get_trip_level()

From: Daniel Lezcano
Date: Wed Sep 27 2023 - 11:00:29 EST


On 21/09/2023 19:54, Rafael J. Wysocki wrote:
From: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>

Make get_trip_level() access the thermal zone's trip table directly
instead of using __thermal_zone_get_trip() which adds overhead related
to the unnecessary bounds checking and copying the trip point data.

Also rearrange the code in it to make it somewhat easier to follow.

The general functionality is not expected to be changed.

Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
---
drivers/thermal/gov_fair_share.c | 22 ++++++++++------------
1 file changed, 10 insertions(+), 12 deletions(-)

Index: linux-pm/drivers/thermal/gov_fair_share.c
===================================================================
--- linux-pm.orig/drivers/thermal/gov_fair_share.c
+++ linux-pm/drivers/thermal/gov_fair_share.c
@@ -21,23 +21,21 @@
*/
static int get_trip_level(struct thermal_zone_device *tz)
{
- struct thermal_trip trip;
- int count;
+ const struct thermal_trip *trip = tz->trips;
+ int i;
- for (count = 0; count < tz->num_trips; count++) {
- __thermal_zone_get_trip(tz, count, &trip);
- if (tz->temperature < trip.temperature)
+ if (tz->temperature < trip->temperature)
+ return 0;
+
+ for (i = 0; i < tz->num_trips - 1; i++) {
+ trip++;
+ if (tz->temperature < trip->temperature)
break;
}

Is it possible to use for_each_thermal_trip() instead ? That would make the code more self-encapsulate

- /*
- * count > 0 only if temperature is greater than first trip
- * point, in which case, trip_point = count - 1
- */
- if (count > 0)
- trace_thermal_zone_trip(tz, count - 1, trip.type);
+ trace_thermal_zone_trip(tz, i, tz->trips[i].type);
- return count;
+ return i;
}
static long get_target_state(struct thermal_zone_device *tz,




--
<http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs

Follow Linaro: <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog