* Yajun Deng <yajun.deng@xxxxxxxxx> wrote:
The member back in struct sched_rt_entity only related to RT_GROUP_SCHED,Yeah, so I agree with these changes, but could you please split up this
it should not place out of RT_GROUP_SCHED, move back to RT_GROUP_SCHED
and rename it child.
Init child when parent isn't NULL in init_tg_rt_entry().
Introduce for_each_sched_rt_entity_reverse() to iterate rt_se from
top to down.
Signed-off-by: Yajun Deng <yajun.deng@xxxxxxxxx>
Reported-by: kernel test robot <oliver.sang@xxxxxxxxx>
Closes: https://lore.kernel.org/oe-lkp/202308031034.4369b15b-oliver.sang@xxxxxxxxx
patch into 3 separate patches:
sched/rt: Move sched_rt_entity::back to under the CONFIG_RT_GROUP_SCHED block
sched/rt: Rename sched_rt_entity::back to sched_rt_entity::child
sched/rt: Introduce for_each_sched_rt_entity_reverse() & use it
Thanks,
Ingo