Re: [PATCH net-next v2 2/2] net: dsa: Rename IFLA_DSA_MASTER to IFLA_DSA_CONDUIT

From: Stephen Hemminger
Date: Wed Oct 11 2023 - 19:30:09 EST


On Wed, 11 Oct 2023 15:20:26 -0700
Florian Fainelli <florian.fainelli@xxxxxxxxxxxx> wrote:

> enum {
> IFLA_DSA_UNSPEC,
> - IFLA_DSA_MASTER,
> + IFLA_DSA_CONDUIT,
> + /* Deprecated, use IFLA_DSA_CONDUIT insted */
> + IFLA_DSA_MASTER = IFLA_DSA_CONDUIT,
> __IFLA_DSA_MAX,
> };

minor nit s/insted/instead/

I don't know if it would be acceptable in the kernel UAPI but what
we did in DPDK for similar situation to cause warning on use of deprecated value.



/**
* Macro to mark macros and defines scheduled for removal
*/
#if defined(RTE_CC_GCC) || defined(RTE_CC_CLANG)
#define RTE_PRAGMA(x) _Pragma(#x)
#define RTE_PRAGMA_WARNING(w) RTE_PRAGMA(GCC warning #w)
#define RTE_DEPRECATED(x) RTE_PRAGMA_WARNING(#x is deprecated)
#else
#define RTE_DEPRECATED(x)
#endif

...
#define RTE_DEV_WHITELISTED \
RTE_DEPRECATED(RTE_DEV_WHITELISTED) RTE_DEV_ALLOWED
#define RTE_DEV_BLACKLISTED \
RTE_DEPRECATED(RTE_DEV_BLACKLISTED) RTE_DEV_BLOCKED