Re: [PATCH v2 3/7] arm64: dts: mt8183: Add kukui katsu board

From: AngeloGioacchino Del Regno
Date: Wed Oct 25 2023 - 04:25:46 EST


Il 24/10/23 23:22, Hsin-Yi Wang ha scritto:
katsu is also known as ASUS Chromebook Detachable CZ1.

Signed-off-by: Hsin-Yi Wang <hsinyi@xxxxxxxxxxxx>
---
v1->v2: non sku38 is sku32
---
arch/arm64/boot/dts/mediatek/Makefile | 2 +
.../dts/mediatek/mt8183-kukui-katsu-sku32.dts | 40 +++++++++++++++++
.../dts/mediatek/mt8183-kukui-katsu-sku38.dts | 44 +++++++++++++++++++
3 files changed, 86 insertions(+)
create mode 100644 arch/arm64/boot/dts/mediatek/mt8183-kukui-katsu-sku32.dts
create mode 100644 arch/arm64/boot/dts/mediatek/mt8183-kukui-katsu-sku38.dts

diff --git a/arch/arm64/boot/dts/mediatek/Makefile b/arch/arm64/boot/dts/mediatek/Makefile
index e6e7592a3645..a13419e67e8e 100644
--- a/arch/arm64/boot/dts/mediatek/Makefile
+++ b/arch/arm64/boot/dts/mediatek/Makefile
@@ -36,6 +36,8 @@ dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-jacuzzi-willow-sku0.dtb
dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-jacuzzi-willow-sku1.dtb
dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-kakadu.dtb
dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-kakadu-sku22.dtb
+dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-katsu-sku32.dtb
+dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-katsu-sku38.dtb
dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-kodama-sku16.dtb
dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-kodama-sku272.dtb
dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-kodama-sku288.dtb
diff --git a/arch/arm64/boot/dts/mediatek/mt8183-kukui-katsu-sku32.dts b/arch/arm64/boot/dts/mediatek/mt8183-kukui-katsu-sku32.dts
new file mode 100644
index 000000000000..9fa205c06c74
--- /dev/null
+++ b/arch/arm64/boot/dts/mediatek/mt8183-kukui-katsu-sku32.dts
@@ -0,0 +1,40 @@
+// SPDX-License-Identifier: (GPL-2.0 OR MIT)
+/*
+ * Copyright 2023 Google LLC
+ */
+
+/dts-v1/;
+#include "mt8183-kukui-kakadu.dtsi"
+#include "mt8183-kukui-audio-da7219-rt1015p.dtsi"
+
+/ {
+ model = "Google katsu board";
+ chassis-type = "tablet";
+ compatible = "google,katsu-sku32", "google,katsu", "mediatek,mt8183";
+};
+
+&i2c0 {
+ status = "okay";
+

The i2c0 node already inherits status = "okay" from mt8183-kukui-kakadu.dtsi,
this is redundant.

+ /delete-node/touchscreen@10;

You can definitely avoid those ugly /delete-node/ statements: if you check more
closely, mt8183-kukui-kakadu.dtsi is used by only two *.dts files.

I would propose to move the touchscreen@10 node from kakadu.dtsi to kakadu.dts
and kakadu-sku22.dts: in my opinion, that will make things more readable, as
every board defines its own touchscreen.

It would be a different story if we had to duplicate that @10 node for something
like five times or more, but that's not the case.

+ touchscreen1: touchscreen@5d {
+ compatible = "goodix,gt7375p";
+ reg = <0x5d>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&open_touch>;
+

This....

+ interrupt-parent = <&pio>;
+ interrupts = <155 IRQ_TYPE_LEVEL_LOW>;

...should be done in one line, like so:

interrupts-extended = <&pio 155 IRQ_TYPE_LEVEL_LOW>;

+
+ reset-gpios = <&pio 156 GPIO_ACTIVE_LOW>;
+ vdd-supply = <&lcd_pp3300>;
+ };
+};
+
+&panel {
+ compatible = "starry,2081101qfh032011-53g";

Actually, same comment goes for the panel node: kakadu.dtsi defines a panel
compatible "boe,tv105wum-nw0" but then you're overriding it here with the
starry panel.

You could leave the status = "okay" in kakadu.dtsi and move the panel compatible
to each *.dts board file, therefore increasing readability.

+};
+
+&qca_wifi {
+ qcom,ath10k-calibration-variant = "GO_KATSU";
+};

Same comment applies to sku38, of course.

Regards,
Angelo