Re: [PATCH v4 1/7] topology: add a new arch_scale_freq_reference

From: Ingo Molnar
Date: Fri Oct 27 2023 - 05:31:18 EST



* Vincent Guittot <vincent.guittot@xxxxxxxxxx> wrote:

> --- a/include/linux/arch_topology.h
> +++ b/include/linux/arch_topology.h
> @@ -27,6 +27,13 @@ static inline unsigned long topology_get_cpu_scale(int cpu)
>
> void topology_set_cpu_scale(unsigned int cpu, unsigned long capacity);
>
> +DECLARE_PER_CPU(unsigned long, capacity_ref_freq);
> +
> +static inline unsigned long topology_get_freq_ref(int cpu)
> +{
> + return per_cpu(capacity_ref_freq, cpu);
> +}
> +
> DECLARE_PER_CPU(unsigned long, arch_freq_scale);

So mind naming it in a way that expresses that this is indeed a maximum
frequency? arch_scale_ref_freq_max or so?

Also, is there any particular concept behind naming one new symbol
'freq_ref', the other 'ref_freq'? If not then please standardize on one
variant.

Thanks,

Ingo