RE: [Intel-wired-lan] [PATCH iwl-next 4/6] i40e: Use DECLARE_BITMAP for flags field in i40e_hw

From: Pucha, HimasekharX Reddy
Date: Tue Oct 31 2023 - 07:15:59 EST


> -----Original Message-----
> From: Intel-wired-lan <intel-wired-lan-bounces@xxxxxxxxxx> On Behalf Of Ivan Vecera
> Sent: Saturday, October 21, 2023 1:08 AM
> To: netdev@xxxxxxxxxxxxxxx
> Cc: Eric Dumazet <edumazet@xxxxxxxxxx>; dacampbe@xxxxxxxxxx; Brandeburg, Jesse <jesse.brandeburg@xxxxxxxxx>; open list <linux-kernel@xxxxxxxxxxxxxxx>; Nguyen, Anthony L <anthony.l.nguyen@xxxxxxxxx>; moderated list:INTEL ETHERNET DRIVERS <intel-wired-lan@xxxxxxxxxxxxxxxx>; Keller, Jacob E <jacob.e.keller@xxxxxxxxx>; Jakub Kicinski <kuba@xxxxxxxxxx>; Paolo Abeni <pabeni@xxxxxxxxxx>; David S. Miller <davem@xxxxxxxxxxxxx>
> Subject: [Intel-wired-lan] [PATCH iwl-next 4/6] i40e: Use DECLARE_BITMAP for flags field in i40e_hw
>
> Convert flags field in i40e_hw from u64 to bitmap and its usage
> to use bit access functions and rename the field to 'caps' as
> this field describes capabilities that are set once on init and
> read many times later.
>
> Changes:
> - Convert "hw_ptr->flags & FLAG" to "test_bit(FLAG, ...)"
> - Convert "hw_ptr->flags |= FLAG" to "set_bit(FLAG, ...)"
> - Convert "hw_ptr->flags &= ~FLAG" to "clear_bit(FLAG, ...)"
> - Rename i40e_hw.flags to i40e_hw.caps
> - Rename i40e_set_hw_flags() to i40e_set_hw_caps()
> - Adjust caps names so they are prefixed by I40E_HW_CAP_ and existing
> _CAPABLE suffixes are stripped
>
> Signed-off-by: Ivan Vecera <ivecera@xxxxxxxxxx>
> ---
> drivers/net/ethernet/intel/i40e/i40e_adminq.c | 38 +++++++++----------
> drivers/net/ethernet/intel/i40e/i40e_common.c | 20 +++++-----
> drivers/net/ethernet/intel/i40e/i40e_dcb.c | 2 +-
> .../net/ethernet/intel/i40e/i40e_ethtool.c | 10 ++---
> drivers/net/ethernet/intel/i40e/i40e_main.c | 4 +-
> drivers/net/ethernet/intel/i40e/i40e_nvm.c | 10 ++---
> drivers/net/ethernet/intel/i40e/i40e_type.h | 22 ++++++-----
> 7 files changed, 55 insertions(+), 51 deletions(-)
>

Tested-by: Pucha Himasekhar Reddy <himasekharx.reddy.pucha@xxxxxxxxx> (A Contingent worker at Intel)