From: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
Both trip_point_temp_store() and trip_point_hyst_store() use
thermal_zone_set_trip() to update a given trip point, but none of them
actually needs to change more than one field in struct thermal_trip
representing it. However, each of them effectively calls
__thermal_zone_get_trip() twice in a row for the same trip index value,
once directly and once via thermal_zone_set_trip(), which is not
particularly efficient, and the way in which thermal_zone_set_trip()
carries out the update is not particularly straightforward.
Moreover, some checks done by them both need not go under the thermal
zone lock and code duplication between them can be reduced quite a bit
by moving the majority of logic into thermal_zone_set_trip().
Rework all of the above functions to address the above.
No intentional functional impact.
Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
---
v2 -> v3: Fix missing return statement in thermal_zone_set_trip() (Lukasz).
v1 -> v2:
* Fix 2 typos in the changelog (Lukasz).
* Split one change into the [1/2].
---
drivers/thermal/thermal_core.h | 9 ++++++
drivers/thermal/thermal_sysfs.c | 52 ++++++++--------------------------
drivers/thermal/thermal_trip.c | 60 +++++++++++++++++++++++++++-------------
include/linux/thermal.h | 3 --
4 files changed, 62 insertions(+), 62 deletions(-)