Re: [PATCH] Input: pxrc - simplify mutex handling with guard macro

From: Dmitry Torokhov
Date: Fri Dec 01 2023 - 18:33:31 EST


On Fri, Dec 01, 2023 at 02:29:22PM +0100, Johan Hovold wrote:
> On Fri, Dec 01, 2023 at 01:08:45PM +0100, Marcus Folkesson wrote:
> > Use the guard(mutex) macro for handle mutex lock/unlocks.
> >
> > Signed-off-by: Marcus Folkesson <marcus.folkesson@xxxxxxxxx>
>
> A couple of drive-by comments below.
>
> > ---
> > drivers/input/joystick/pxrc.c | 27 +++++++++++----------------
> > 1 file changed, 11 insertions(+), 16 deletions(-)
> >
> > diff --git a/drivers/input/joystick/pxrc.c b/drivers/input/joystick/pxrc.c
> > index ea2bf5951d67..3c3bf7179b46 100644
> > --- a/drivers/input/joystick/pxrc.c
> > +++ b/drivers/input/joystick/pxrc.c
> > @@ -5,15 +5,17 @@
> > * Copyright (C) 2018 Marcus Folkesson <marcus.folkesson@xxxxxxxxx>
> > */
> >
> > -#include <linux/kernel.h>
> > +#include <linux/cleanup.h>
> > #include <linux/errno.h>
> > -#include <linux/slab.h>
> > +#include <linux/input.h>
> > +#include <linux/kernel.h>
> > #include <linux/module.h>
> > +#include <linux/mutex.h>
> > +#include <linux/slab.h>
> > #include <linux/uaccess.h>
> > +
> > #include <linux/usb.h>
> > #include <linux/usb/input.h>
> > -#include <linux/mutex.h>
> > -#include <linux/input.h>
>
> Looks like an unrelated change.
>
> > #define PXRC_VENDOR_ID 0x1781
> > #define PXRC_PRODUCT_ID 0x0898
> > @@ -89,25 +91,20 @@ static int pxrc_open(struct input_dev *input)
> > dev_err(&pxrc->intf->dev,
> > "%s - usb_submit_urb failed, error: %d\n",
> > __func__, retval);
> > - retval = -EIO;
> > - goto out;
> > + return -EIO;
> > }
> >
> > pxrc->is_open = true;
> > -
> > -out:
> > - mutex_unlock(&pxrc->pm_mutex);
> > - return retval;
> > + return 0;
> > }
>
> Eh, this looks obviously broken. Did you not test this before
> submitting? I assume lockdep would complain loudly too.
>
> You're apparently the author of this driver and can test it, but I fear
> the coming onslaught of untested guard conversions from the "cleanup"
> crew. Not sure I find the result generally more readable either.

Yeah, for the code without conditions (like pxrc_close) the utility is
questionable, but I guess it is just a matter of getting used to the new
facilities...

Thanks.

--
Dmitry