[PATCH v3 iwl-next] i40e: Use correct buffer size in i40e_dbg_command_read

From: Kunwu Chan
Date: Sun Dec 03 2023 - 20:45:17 EST


The size of "i40e_dbg_command_buf" is 256, the size of "name"
depends on "IFNAMSIZ", plus a null character and format size,
the total size is more than 256.

Improve readability and maintainability by replacing a hardcoded string
allocation and formatting by the use of the kasprintf() helper.

Fixes: 02e9c290814c ("i40e: debugfs interface")
Signed-off-by: Kunwu Chan <chentao@xxxxxxxxxx>
Suggested-by: Simon Horman <horms@xxxxxxxxxx>
Suggested-by: Alexander Lobakin <aleksander.lobakin@xxxxxxxxx>
---
v2
- Update the size calculation with IFNAMSIZ and sizeof(i40e_dbg_command_buf)
v3
- Use kasprintf to improve readability and maintainability
---
drivers/net/ethernet/intel/i40e/i40e_debugfs.c | 15 +++++++--------
1 file changed, 7 insertions(+), 8 deletions(-)

diff --git a/drivers/net/ethernet/intel/i40e/i40e_debugfs.c b/drivers/net/ethernet/intel/i40e/i40e_debugfs.c
index 88240571721a..a176de89de9c 100644
--- a/drivers/net/ethernet/intel/i40e/i40e_debugfs.c
+++ b/drivers/net/ethernet/intel/i40e/i40e_debugfs.c
@@ -72,23 +72,22 @@ static ssize_t i40e_dbg_command_read(struct file *filp, char __user *buffer,
{
struct i40e_pf *pf = filp->private_data;
int bytes_not_copied;
- int buf_size = 256;
- char *buf;
+ char *buf = NULL;
int len;

/* don't allow partial reads */
if (*ppos != 0)
return 0;
- if (count < buf_size)
- return -ENOSPC;

- buf = kzalloc(buf_size, GFP_KERNEL);
+ buf = kasprintf(GFP_KERNEL, "%s: %s\n",
+ pf->vsi[pf->lan_vsi]->netdev->name,
+ i40e_dbg_command_buf);
if (!buf)
return -ENOSPC;

- len = snprintf(buf, buf_size, "%s: %s\n",
- pf->vsi[pf->lan_vsi]->netdev->name,
- i40e_dbg_command_buf);
+ len = strlen(buf);
+ if (count < len)
+ return -ENOSPC;

bytes_not_copied = copy_to_user(buffer, buf, len);
kfree(buf);
--
2.34.1