Re: [PATCH v2 03/35] lib/sbitmap; make __sbitmap_get_word() using find_and_set_bit()

From: Jens Axboe
Date: Mon Dec 04 2023 - 13:41:06 EST


On 12/3/23 12:32 PM, Yury Norov wrote:
> diff --git a/lib/sbitmap.c b/lib/sbitmap.c
> index d0a5081dfd12..b21aebd07fd6 100644
> --- a/lib/sbitmap.c
> +++ b/lib/sbitmap.c
> @@ -133,38 +133,11 @@ void sbitmap_resize(struct sbitmap *sb, unsigned int depth)
> }
> EXPORT_SYMBOL_GPL(sbitmap_resize);
>
> -static int __sbitmap_get_word(unsigned long *word, unsigned long depth,
> +static inline int __sbitmap_get_word(unsigned long *word, unsigned long depth,
> unsigned int hint, bool wrap)
> {
> - int nr;
> -
> - /* don't wrap if starting from 0 */
> - wrap = wrap && hint;
> -
> - while (1) {
> - nr = find_next_zero_bit(word, depth, hint);
> - if (unlikely(nr >= depth)) {
> - /*
> - * We started with an offset, and we didn't reset the
> - * offset to 0 in a failure case, so start from 0 to
> - * exhaust the map.
> - */
> - if (hint && wrap) {
> - hint = 0;
> - continue;
> - }
> - return -1;
> - }
> -
> - if (!test_and_set_bit_lock(nr, word))
> - break;
> -
> - hint = nr + 1;
> - if (hint >= depth - 1)
> - hint = 0;
> - }
> -
> - return nr;
> + return wrap ? find_and_set_bit_wrap_lock(word, depth, hint) :
> + find_and_set_next_bit_lock(word, depth, hint);
> }

Please make this:

if (wrap)
return find_and_set_bit_wrap_lock(word, depth, hint) :
return find_and_set_next_bit_lock(word, depth, hint);

so this is a lot more readable.

--
Jens Axboe