Re: [PATCH v7 2/2] iio: adc: ad7173: add AD7173 driver

From: Ceclan Dumitru
Date: Tue Dec 05 2023 - 08:49:50 EST




On 12/5/23 15:42, Dumitru Ceclan wrote:
> The AD7173 family offer a complete integrated Sigma-Delta ADC solution
> which can be used in high precision, low noise single channel
> applications or higher speed multiplexed applications. The Sigma-Delta
> ADC is intended primarily for measurement of signals close to DC but also
> delivers outstanding performance with input bandwidths out to ~10kHz.
>


V6 -> V7

- format Kconfig supported models using '-'

- include types.h instead of stddef.h

- change device_info->num_gpios type to u8

- reorder fields in ad7173_state, place ad_sigma_delta

- reorder fields in ad7173_device_info, group by type

- add default case in read_raw()

- rename ad7173_debug() to ad7173_debug_reg_access()

- remove explicit u8 cast

- remove return 0; for offset in read_raw()

- add '\n' to error messages

- reorder probe variables -> reversed xmas tree

- remove redundant inner commas in of_match and id_table

- simplify selected reference code by setting default value and
ignoring fwnode_property_read_string() error

- use match_string() for finding selected reference

- err on no channels specified

- add missing fwnode_handle_put(child) on err return branches

- remove spi_set_drvdata() from probe

- remove offset variable from find_live_config(), not used

- add comment showing a generic LRU implementation might be used if one
will exist



- MISC: add blank line to chanel_config struct, trailing comma
ref_sel_str[],
remove blank line in update_scan_mode(), add spaces around '/'