Re: [PATCH 04/18] serial: sc16is7xx: improve do/while loop in sc16is7xx_irq()
From: Hugo Villeneuve
Date: Wed Dec 20 2023 - 11:04:35 EST
On Wed, 20 Dec 2023 17:42:42 +0200
Andy Shevchenko <andy.shevchenko@xxxxxxxxx> wrote:
> On Tue, Dec 19, 2023 at 12:18:48PM -0500, Hugo Villeneuve wrote:
> > From: Hugo Villeneuve <hvilleneuve@xxxxxxxxxxxx>
> >
> > Simplify and improve readability by replacing while(1) loop with
> > do {} while, and by using the keep_polling variable as the exit
> > condition, making it more explicit.
>
> ...
>
> > + bool keep_polling;
>
> > +
>
> Stray blank line. Otherwise LGTM.
Yes, and I just realized I should also change:
do {
keep_polling = false;
int i;
...
to:
do {
int i;
keep_polling = false;
...
Hugo Villeneuve