Re: [PATCH v4 2/6] dt-bindings: pwm: amlogic: add new compatible for meson8 pwm type

From: Krzysztof Kozlowski
Date: Sat Dec 23 2023 - 09:02:50 EST


On 22/12/2023 12:16, Jerome Brunet wrote:
> Add a new compatible for the pwm found in the meson8 to sm1 Amlogic SoCs,
> dealing with clocks differently. This does not enable new HW. It is meant
> to fix a bad DT ABI for the currently supported HW.
>
> The original clock bindings describe which input the PWM channel
> multiplexer should pick among its possible parents, which are
> hard-coded in the driver. As such, it is a setting tied to the driver
> implementation and does not describe the HW.
>
> The new bindings introduce here describe the clocks input of the PWM block
> as they exist.
>
> The old compatible is deprecated but kept to maintain ABI compatibility.
>
> The SoC specific compatibles introduced match the SoC families supported
> by the original bindings.
>
> Signed-off-by: Jerome Brunet <jbrunet@xxxxxxxxxxxx>
> ---
> .../devicetree/bindings/pwm/pwm-amlogic.yaml | 50 +++++++++++++++++--
> 1 file changed, 46 insertions(+), 4 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/pwm/pwm-amlogic.yaml b/Documentation/devicetree/bindings/pwm/pwm-amlogic.yaml
> index a1d382aacb82..eece390114a3 100644
> --- a/Documentation/devicetree/bindings/pwm/pwm-amlogic.yaml
> +++ b/Documentation/devicetree/bindings/pwm/pwm-amlogic.yaml
> @@ -21,23 +21,35 @@ properties:
> - amlogic,meson-g12a-ee-pwm
> - amlogic,meson-g12a-ao-pwm-ab
> - amlogic,meson-g12a-ao-pwm-cd
> - - amlogic,meson-s4-pwm
> + deprecated: true
> - items:
> - const: amlogic,meson-gx-pwm
> - const: amlogic,meson-gxbb-pwm
> + deprecated: true
> - items:
> - const: amlogic,meson-gx-ao-pwm
> - const: amlogic,meson-gxbb-ao-pwm
> + deprecated: true
> - items:
> - const: amlogic,meson8-pwm
> - const: amlogic,meson8b-pwm
> + deprecated: true
> + - const: amlogic,meson8-pwm-v2
> + - items:
> + - enum:
> + - amlogic,meson8b-pwm-v2
> + - amlogic,meson-gxbb-pwm-v2
> + - amlogic,meson-axg-pwm-v2
> + - amlogic,meson-g12-pwm-v2
> + - const: amlogic,meson8-pwm-v2
> + - const: amlogic,meson-s4-pwm

If there is going to be resend:
This and amlogic,meson8-pwm-v2 before items: should be just in enum,
it's easier to read.

>
> reg:
> maxItems: 1
>
> clocks:
> minItems: 1
> - maxItems: 2
> + maxItems: 4
>
> clock-names:
> minItems: 1
> @@ -58,7 +70,6 @@ allOf:
> compatible:
> contains:
> enum:
> - - amlogic,meson8-pwm

I don't understand why removing it here.

The rest looks ok.
Best regards,
Krzysztof