Re: [PATCH 77/82] virtio: Refactor intentional wrap-around test

From: Eugenio Perez Martin
Date: Fri Jan 26 2024 - 14:35:06 EST


On Tue, Jan 23, 2024 at 2:28 AM Kees Cook <keescook@xxxxxxxxxxxx> wrote:
>
> In an effort to separate intentional arithmetic wrap-around from
> unexpected wrap-around, we need to refactor places that depend on this
> kind of math. One of the most common code patterns of this is:
>
> VAR + value < VAR
>
> Notably, this is considered "undefined behavior" for signed and pointer
> types, which the kernel works around by using the -fno-strict-overflow
> option in the build[1] (which used to just be -fwrapv). Regardless, we
> want to get the kernel source to the position where we can meaningfully
> instrument arithmetic wrap-around conditions and catch them when they
> are unexpected, regardless of whether they are signed[2], unsigned[3],
> or pointer[4] types.
>
> Refactor open-coded wrap-around addition test to use add_would_overflow().
> This paves the way to enabling the wrap-around sanitizers in the future.
>
> Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1]
> Link: https://github.com/KSPP/linux/issues/26 [2]
> Link: https://github.com/KSPP/linux/issues/27 [3]
> Link: https://github.com/KSPP/linux/issues/344 [4]
> Cc: "Michael S. Tsirkin" <mst@xxxxxxxxxx>
> Cc: Jason Wang <jasowang@xxxxxxxxxx>
> Cc: Xuan Zhuo <xuanzhuo@xxxxxxxxxxxxxxxxx>
> Cc: virtualization@xxxxxxxxxxxxxxx
> Signed-off-by: Kees Cook <keescook@xxxxxxxxxxxx>

Reviewed-by: Eugenio Pérez <eperezma@xxxxxxxxxx>

> ---
> drivers/virtio/virtio_pci_modern_dev.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/virtio/virtio_pci_modern_dev.c b/drivers/virtio/virtio_pci_modern_dev.c
> index 0d3dbfaf4b23..710d3bd45b4f 100644
> --- a/drivers/virtio/virtio_pci_modern_dev.c
> +++ b/drivers/virtio/virtio_pci_modern_dev.c
> @@ -59,7 +59,7 @@ vp_modern_map_capability(struct virtio_pci_modern_device *mdev, int off,
>
> length -= start;
>
> - if (start + offset < offset) {
> + if (add_would_overflow(offset, start)) {
> dev_err(&dev->dev,
> "virtio_pci: map wrap-around %u+%u\n",
> start, offset);
> @@ -81,7 +81,7 @@ vp_modern_map_capability(struct virtio_pci_modern_device *mdev, int off,
> if (len)
> *len = length;
>
> - if (minlen + offset < minlen ||
> + if (add_would_overflow(minlen, offset) ||
> minlen + offset > pci_resource_len(dev, bar)) {
> dev_err(&dev->dev,
> "virtio_pci: map virtio %zu@%u "
> --
> 2.34.1
>
>