This is an effort to get rid of all multiplications from allocation
functions in order to prevent integer overflows [1].
As the cpu variable is a pointer to "struct bcm7038_l1_cpu" and this
structure ends in a flexible array:
struct bcm7038_l1_cpu {
void __iomem *map_base;
u32 mask_cache[];
};
the preferred way in the kernel is to use the struct_size() helper to
do the arithmetic instead of the argument "size + count * size" in the
kzalloc() function.
This way, the code is more readable and more safer.
Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
Link: https://github.com/KSPP/linux/issues/162 [2]
Signed-off-by: Erick Archer <erick.archer@xxxxxxx>
Attachment:
smime.p7s
Description: S/MIME Cryptographic Signature