Re: [PATCH net-next v3 1/7] dma: compile-out DMA sync op calls when not used

From: Robin Murphy
Date: Mon Feb 26 2024 - 11:27:47 EST


On 19/02/2024 12:53 pm, Alexander Lobakin wrote:
From: Robin Murphy <robin.murphy@xxxxxxx>
Date: Wed, 14 Feb 2024 17:20:50 +0000

On 2024-02-14 4:21 pm, Alexander Lobakin wrote:

[...]

-static inline void dma_sync_single_for_cpu(struct device *dev,
dma_addr_t addr,
-        size_t size, enum dma_data_direction dir)
+static inline void __dma_sync_single_for_cpu(struct device *dev,
+        dma_addr_t addr, size_t size, enum dma_data_direction dir)

To me it would feel more logical to put all the wrappers inside the
#ifdef CONFIG_HAS_DMA and not touch these stubs at all (what does it
mean to skip an inline no-op?). Or in fact, if dma_skip_sync() is
constant false for !HAS_DMA, then we could also just make the external
function declarations unconditional and remove the stubs. Not a critical
matter though, and I defer to whatever Christoph thinks is most
maintainable.

It's done like that due to that I'm adding a runtime check in the second
patch. I don't feel like touching this twice makes sense.

Huh? Why would anything need touching twice? All I'm saying is that it's pretty pointless to add any invocations of dma_skip_sync() in !HAS_DMA paths where we already know the whole API is stubbed out anyway. The only cases which are worth differentiating here are HAS_DMA + DMA_NEED_SYNC vs. HAS_DMA + !DMA_NEED_SYNC (with the subsequent runtime check then just subdividing the former).


[...]

@@ -348,18 +348,72 @@ static inline void dma_unmap_single_attrs(struct
device *dev, dma_addr_t addr,
      return dma_unmap_page_attrs(dev, addr, size, dir, attrs);
  }
  +static inline void __dma_sync_single_range_for_cpu(struct device *dev,
+        dma_addr_t addr, unsigned long offset, size_t size,
+        enum dma_data_direction dir)
+{
+    __dma_sync_single_for_cpu(dev, addr + offset, size, dir);
+}
+
+static inline void __dma_sync_single_range_for_device(struct device
*dev,
+        dma_addr_t addr, unsigned long offset, size_t size,
+        enum dma_data_direction dir)
+{
+    __dma_sync_single_for_device(dev, addr + offset, size, dir);
+}

There is no need to introduce these two.

I already replied to this in the previous thread. Some subsys may want
to check for the shortcut earlier to avoid call ladders of their own
functions. See patch 6 for example where I use this one.

Ugh, no. If the page pool code wants to be clever poking around and sidestepping parts of the documented API, it can flippin' well open-code a single addition to call __dma_sync_single_for_device() directly itself. I'm not at all keen on having to maintain "common" APIs for such niche trickery.

Thanks,
Robin.