Re: [PATCH v4 14/36] lib: add allocation tagging support for memory allocation profiling

From: Vlastimil Babka
Date: Wed Feb 28 2024 - 03:29:35 EST


On 2/21/24 20:40, Suren Baghdasaryan wrote:
>
> +static inline void alloc_tag_sub(union codetag_ref *ref, size_t bytes)
> +{
> + __alloc_tag_sub(ref, bytes);
> +}
> +
> +static inline void alloc_tag_sub_noalloc(union codetag_ref *ref, size_t bytes)
> +{
> + __alloc_tag_sub(ref, bytes);
> +}
> +

Nit: just notice these are now the same and maybe you could just drop both
wrappers and rename __alloc_tag_sub to alloc_tag_sub?