Re: [PATCH v2 0/3] Trivial code cleanup patches

From: Fabio M. De Francesco
Date: Wed Mar 20 2024 - 15:51:18 EST


On Tuesday, 19 March 2024 07:04:34 CET Fabio M. De Francesco wrote:
> On Monday, 18 March 2024 20:54:09 CET Ayush Tiwari wrote:
> > Address different kinds of checkpatch complains for the rtl8712 module
> > to ensure adherence to coding style guidelines.
> >
> > Changes in v2: Checked any possible reuse of backup_PMKID_list
> > manually and rebuilt,

No you didn't do what you are saying.

> rebooted the kernel and loaded the driver
> > with modprobe.
>
> You have not made any changes to any of the three patches in this series.
> No changes in commit messages and no changes in code. Am I missing
> something?
>
> So why did you submit a v2 of this series?
>
> Fabio

Julia commented on patch 1/3. You should either reply that everything is
correct (if it is) or fix your patch. Please don't send new versions that
don't change anything and don't ignore comments (mine included).

> > Ayush Tiwari (3):
> > staging: rtl8712: rename backupPMKIDList to backup_PMKID_list

This patch introduces errors. You haven't compiled this module, otherwise
you would have noticed that. Always compile your changes (preferably with
CONFIG_WERROR set).

Please read the output of git-grep:

[fabio@linux]$ git grep backupPMKIDList drivers/staging/rtl8712
drivers/staging/rtl8712/mlme_linux.c: static struct RT_PMKID_LIST
backupPMKIDList[NUM_PMKID_CACHE];
drivers/staging/rtl8712/mlme_linux.c: memcpy(&backupPMKIDList[0],
drivers/staging/rtl8712/mlme_linux.c: &backupPMKIDList[0],

Can you see how patch 1/3 introduces errors?

Fabio

> > staging: rtl8712: rename backupPMKIDIndex to backup_PMKID_index
> > staging: rtl8712: rename backupTKIPCountermeasure to
> >
> > backup_TKIP_countermeasure
> >
> > drivers/staging/rtl8712/mlme_linux.c | 18 +++++++++---------
> > 1 file changed, 9 insertions(+), 9 deletions(-)