Re: [PATCH] Staging: rtl8712: Removed unnecessary parentheses

From: Philipp Hortmann
Date: Sat Mar 23 2024 - 18:19:54 EST


On 3/22/24 16:11, Brandon Crain wrote:
Please make your "Subject" line more unique. Consider that we may end up
with having dozen of commits like yours, all of them referring to
different removals and all without the necessary information to tell what they differ in (except the driver/subsystem). So it would help if you add the changed file or function to make it more unique.
Removed uneccessary parentheses from source file

Please use a full sentences with final dot. Always consider that the why is most important to answer. In your case the answer would be "because it is unnecessary" My preferred proposal would be:

Remove unnecessary parentheses to increase readability.


Signed-off-by: Brandon Crain <bcrain1606@xxxxxxxxx>
---
drivers/staging/rtl8712/recv_linux.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/staging/rtl8712/recv_linux.c b/drivers/staging/rtl8712/recv_linux.c
index 215fca4abb3a..2bf4661432a9 100644
--- a/drivers/staging/rtl8712/recv_linux.c
+++ b/drivers/staging/rtl8712/recv_linux.c
@@ -105,7 +105,7 @@ void r8712_recv_indicatepkt(struct _adapter *adapter,
skb->data = recvframe->u.hdr.rx_data;
skb->len = recvframe->u.hdr.len;
skb_set_tail_pointer(skb, skb->len);
- if ((attrib->tcpchk_valid == 1) && (attrib->tcp_chkrpt == 1))
+ if (attrib->tcpchk_valid == 1 && attrib->tcp_chkrpt == 1)

I am not so happy with this proposal I need to know the exact rules that the == has priority over &&. So I like to read it with brackets.

skb->ip_summed = CHECKSUM_UNNECESSARY;
else
skb->ip_summed = CHECKSUM_NONE;

If you send in a second version of this patch please use a change history. Description from Dan under:
https://staticthinking.wordpress.com/2022/07/27/how-to-send-a-v2-patch/

Thanks for your support.

Bye Philipp