[PATCH 0/5] staging: pi433: Rename vars, update param type & remove duplicated code.

From: Shahar Avidar
Date: Thu Mar 28 2024 - 08:13:00 EST


This patchset improves readability & maintainability:
- Rename device related vars.
- Update pi433_receive param type.
- Remove duplicated code in pi433_init.

Shahar Avidar (5):
staging: pi433: Rename struct pi433_device buffer field to tx_buffer.
staging: pi433: Rename struct pi433_device instances to pi433.
staging: pi433: Replace pi433_receive param void type to struct
pi433_device.
staging: pi433: Rename "pi433_dev" of type "dev_t" to "pi433_devt"
staging: pi433: Remove duplicated code using the "goto" error recovery
scheme.

drivers/staging/pi433/pi433_if.c | 690 +++++++++++++++----------------
1 file changed, 345 insertions(+), 345 deletions(-)


base-commit: 20952655235dd9b1447829591774f1d8561f7c6a
prerequisite-patch-id: 91943193af2fea74182be67fb583235a3fbeb77b
prerequisite-patch-id: 2cad031ba6a0782a67ab1645ff034a8be65c2e76
prerequisite-patch-id: 1a852ed8f9d133aec7c651fd9007e59e39c55fb7
--
2.34.1