[PATCH 0/4] SLUB: improve filling cpu partial a bit in get_partial_node()
From: xiongwei.song
Date: Sat Mar 30 2024 - 22:43:50 EST
From: Xiongwei Song <xiongwei.song@xxxxxxxxxxxxx>
This series is to remove the unnecessary check for filling cpu partial
and improve the readability.
Introduce slub_get_cpu_partial() and dummy function to prevent compiler
warning with CONFIG_SLUB_CPU_PARTIAL disabled. This is done in patch 2.
Use the helper in patch 3 and 4.
No functionality changed.
Actually, the series is the improvement of patch below:
https://lore.kernel.org/lkml/934f65c6-4d97-6c4d-b123-4937ede24a99@xxxxxxxxxx/T/
Regards,
Xiongwei
Xiongwei Song (4):
mm/slub: remove the check of !kmem_cache_has_cpu_partial()
mm/slub: add slub_get_cpu_partial() helper
mm/slub: simpilify get_partial_node()
mm/slub: don't read slab->cpu_partial_slabs directly
mm/slub.c | 35 +++++++++++++++++++++++------------
1 file changed, 23 insertions(+), 12 deletions(-)
--
2.27.0