Re: [PATCH v2 03/10] PCI: endpoint: Rename core_init() callback in 'struct pci_epc_event_ops' to init()

From: Niklas Cassel
Date: Tue Apr 02 2024 - 06:52:41 EST


On Mon, Apr 01, 2024 at 09:20:29PM +0530, Manivannan Sadhasivam wrote:
> core_init() callback is used to notify the EPC initialization event to the
> EPF drivers. The 'core' prefix was used indicate that the controller IP
> core has completed initialization. But it serves no purpose as the EPF
> driver will only care about the EPC initialization as a whole and there is
> no real benefit to distinguish the IP core part.
>
> So let's rename the core_init() callback in 'struct pci_epc_event_ops' to
> just init() to make it more clear.
>
> Signed-off-by: Manivannan Sadhasivam <manivannan.sadhasivam@xxxxxxxxxx>
> ---
> drivers/pci/endpoint/functions/pci-epf-mhi.c | 4 ++--
> drivers/pci/endpoint/functions/pci-epf-test.c | 4 ++--
> drivers/pci/endpoint/pci-epc-core.c | 16 ++++++++--------
> include/linux/pci-epf.h | 4 ++--
> 4 files changed, 14 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/pci/endpoint/functions/pci-epf-mhi.c b/drivers/pci/endpoint/functions/pci-epf-mhi.c
> index 280863c0eeb9..b3c26ffd29a5 100644
> --- a/drivers/pci/endpoint/functions/pci-epf-mhi.c
> +++ b/drivers/pci/endpoint/functions/pci-epf-mhi.c
> @@ -716,7 +716,7 @@ static void pci_epf_mhi_dma_deinit(struct pci_epf_mhi *epf_mhi)
> epf_mhi->dma_chan_rx = NULL;
> }
>
> -static int pci_epf_mhi_core_init(struct pci_epf *epf)
> +static int pci_epf_mhi_epc_init(struct pci_epf *epf)
> {
> struct pci_epf_mhi *epf_mhi = epf_get_drvdata(epf);
> const struct pci_epf_mhi_ep_info *info = epf_mhi->info;
> @@ -897,7 +897,7 @@ static void pci_epf_mhi_unbind(struct pci_epf *epf)
> }
>
> static const struct pci_epc_event_ops pci_epf_mhi_epc_event_ops = {
> - .core_init = pci_epf_mhi_core_init,
> + .init = pci_epf_mhi_epc_init,
> };
>
> static const struct pci_epc_bus_event_ops pci_epf_mhi_bus_event_ops = {
> diff --git a/drivers/pci/endpoint/functions/pci-epf-test.c b/drivers/pci/endpoint/functions/pci-epf-test.c
> index 973db0b1bde2..abcb6ca61c4e 100644
> --- a/drivers/pci/endpoint/functions/pci-epf-test.c
> +++ b/drivers/pci/endpoint/functions/pci-epf-test.c
> @@ -731,7 +731,7 @@ static int pci_epf_test_set_bar(struct pci_epf *epf)
> return 0;
> }
>
> -static int pci_epf_test_core_init(struct pci_epf *epf)
> +static int pci_epf_test_epc_init(struct pci_epf *epf)

On V1 you agreed that it is better to remove 'epc' from the naming.
(For both pci-epf-test and pci-epf-mhi).
You seem to have forgotten to address this for V2.


Kind regards,
Niklas