Re: [PATCH 1/2] wordpart.h: Helpers for making u16/u32/u64 values

From: Jani Nikula
Date: Mon Apr 08 2024 - 09:28:51 EST


On Tue, 26 Mar 2024, Michal Wajdeczko <michal.wajdeczko@xxxxxxxxx> wrote:
> On 15.02.2024 23:47, Kees Cook wrote:
>> On Thu, Feb 15, 2024 at 09:40:40PM +0100, Michal Wajdeczko wrote:
>>> On 14.02.2024 23:09, Kees Cook wrote:
>>>> On Wed, Feb 14, 2024 at 10:46:53PM +0100, Michal Wajdeczko wrote:
>>>>> It is quite common practice to make u16, u32 or u64 values from
>>>>> smaller words. Add simple helpers for that.
>>>>>
>>>>> Signed-off-by: Michal Wajdeczko <michal.wajdeczko@xxxxxxxxx>
>>>>> ---
>>>>> v2: new macro names due to conflict with crypto/aria.h
>>>>> explicit cast and truncation everywhere (Alexey)
>>>>> moved to wordpart.h (Andy)
>>>>> ---
>>>>> Cc: Kees Cook <keescook@xxxxxxxxxxxx>
>>>>> Cc: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
>>>>> Cc: Alexey Dobriyan <adobriyan@xxxxxxxxx>
>>>>> Cc: Jani Nikula <jani.nikula@xxxxxxxxx>
>>>>> ---
>>>>> include/linux/wordpart.h | 32 ++++++++++++++++++++++++++++++++
>>>>> 1 file changed, 32 insertions(+)
>>>>>
>>>>> diff --git a/include/linux/wordpart.h b/include/linux/wordpart.h
>>>>> index f6f8f83b15b0..8c75a5355112 100644
>>>>> --- a/include/linux/wordpart.h
>>>>> +++ b/include/linux/wordpart.h
>>>>> @@ -31,6 +31,38 @@
>>>>> */
>>>>> #define lower_16_bits(n) ((u16)((n) & 0xffff))
>>>>>
>>>>> +/**
>>>>> + * make_u16_from_u8 - make u16 value from two u8 values
>>>>> + * @hi: value representing upper 8 bits
>>>>> + * @lo: value representing lower 8 bits
>>>>> + */
>>>>> +#define make_u16_from_u8(hi, lo) ((u16)((u16)(u8)(hi) << 8 | (u8)(lo)))
>>>>
>>>> Do we want to actually do type validation here? Right now it's just
>>>> cast/truncating, which based on the version log is by design. Is silent
>>>> truncation the right thing to do?

Doesn't the name imply strongly enough that we're only interested in the
N bits from each parameter? I think not truncating makes these harder to
use (if it means e.g. casting on the caller side).

>>>
>>> note that even FIELD_PREP() is doing silent truncation and these macros
>>> here could be treated as specialized/simplified variants of FIELD_PREP()
>>> as alternate implementation can look like:
>>
>> Also, isn't all of this endian-specific?

None of this assumes endianness.

> endianness shouldn't matter here
>
> so I guess the only question now is whether we want to have simple
> direct macros like lower|upper_bits() or go with macros build on top of
> the FIELD_PREP_CONST() or drop the idea completely and force the drivers
> to invent the wheel on its own

Yeah, please let's do this so we don't have to keep adding them to
drivers.

BR,
Jani.


--
Jani Nikula, Intel