Re: [PATCH v1 16/31] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers

From: Reinette Chatre
Date: Mon Apr 08 2024 - 23:21:01 EST


Hi James,

On 3/21/2024 9:50 AM, James Morse wrote:
> mon_event_config_{read,write}() are called via IPI and access model
> specific registers to do their work.
>
> To support another architecture, this needs abstracting.
>
> Rename mon_event_config_{read,write}() to have a resctrl_arch_ prefix,
> and move their struct mon_config_info parameter into the restrl_types

Looks like this change is actually moving the struct into include/linux/resctrl.h,
not resctrl_types.h.

> header. This allows another architecture to supply an implementation
> of these.
>
> As struct mon_config_info is now exposed globally, give it a 'resctrl_'
> prefix. MPAM systems need access to the domain to do this work, add
> the resource and domain to struct resctrl_mon_config_info.
>
> Signed-off-by: James Morse <james.morse@xxxxxxx>

..

> diff --git a/include/linux/resctrl.h b/include/linux/resctrl.h
> index bfc63e8219e5..975b80102fbe 100644
> --- a/include/linux/resctrl.h
> +++ b/include/linux/resctrl.h
> @@ -192,6 +192,13 @@ struct resctrl_cpu_sync {
> u32 rmid;
> };
>
> +struct resctrl_mon_config_info {
> + struct rdt_resource *r;
> + struct rdt_domain *d;
> + u32 evtid;
> + u32 mon_config;
> +};
> +

Please use tabs consistently in this file.

Reinette