[RFC PATCH bpf-next v1 0/3] Rename mono_delivery_time to

From: Abhishek Chauhan
Date: Tue Apr 09 2024 - 17:06:27 EST


Patch 1 :- This patch takes care of only renaming the mono delivery
timestamp to tstamp_type with no change in functionality of
existing available code in kernel.

Patch 2 :- Starts assigning tstamp_type with either mono or real and
introduces a new enum in the skbuff.h, again no change in functionality
of the existing available code in kernel , just making the code scalable

Patch 3 :- Additional bit was added to support userspace timestamp to
avoid tstamp drops in the forwarding path when testing TC-ETF.
With this patch i am not sure what impacts it has towards BPF code.
I need upstream BPF community to help me in adding the necessary BPF
changes to avoid any BPF test case failures.
I haven't changed any of the BPF functionalities and hence i need
upstream BPF help to assist me with those changes so i can make them as
part of this patch.


Abhishek Chauhan (3):
net: Rename mono_delivery_time to tstamp_type for scalibilty
net: assign enum to skb->tstamp_type to distinguish between tstamp
net: Add additional bit to support userspace timestamp type

include/linux/skbuff.h | 40 ++++++++++++++++------
include/net/inet_frag.h | 4 +--
net/bridge/netfilter/nf_conntrack_bridge.c | 6 ++--
net/core/dev.c | 2 +-
net/core/filter.c | 8 ++---
net/ipv4/inet_fragment.c | 2 +-
net/ipv4/ip_fragment.c | 2 +-
net/ipv4/ip_output.c | 10 +++---
net/ipv4/raw.c | 2 +-
net/ipv4/tcp_output.c | 14 ++++----
net/ipv6/ip6_output.c | 8 ++---
net/ipv6/netfilter.c | 6 ++--
net/ipv6/netfilter/nf_conntrack_reasm.c | 2 +-
net/ipv6/raw.c | 2 +-
net/ipv6/reassembly.c | 2 +-
net/ipv6/tcp_ipv6.c | 2 +-
net/packet/af_packet.c | 6 ++--
net/sched/act_bpf.c | 4 +--
net/sched/cls_bpf.c | 4 +--
19 files changed, 73 insertions(+), 53 deletions(-)

--
2.25.1